No app battery usage

Didn’t see this covered here. On my T2e emerald under Settings → Battery → Battery usage, no apps are ever displayed.
“Battery usage data isn’t available” is all there is.

Wondering if anyone else has this.

1 Like

I see that also after a reboot, usually data appears after some (hours? days? don’t know :wink: ).

I have apps. /e/ 0.23 on FP3

But the sum is never good. I lost about 50% now but the sum of all apps (complete usage) is 31%. Where’s the rest?

Same for me with /e/ 0.23 on T2e emerald

Coming back to this. Running 1.2-r and there is still no usage data.

Awhile back I thought about installing a third party app to show me things but most had too much going on. Then I remembered I paid for 3C All-In-One Toolbox (back when it was called Android Toolbox and Google dinged them for having Android in their name). Sure it has a whole lot going on but what the hey. Its battery stats was pretty cool.
Just learned that Google restrictions meant the battery stats were limited and an extra legacy battery stats app had to be installed to get the full stats I remember from the past.

On a side note, I remember when Google forced apps to remove SMS permissions if the app wasn’t directly associated with SMS. Even backup programs like Titanium Backup had to resort to an extra addon to backup Call Logs and SMS. 3C Toolbox is in the same boat and has to use a separate app to do full backups of “sensitive data”.

Now it seems that with Android 12, usage access will/is denied to user apps. Yet another reason why I really dislike what Android has become / is becoming (as far as restrictions since Pie).

But I digress.

1 Like


I have the same issue on my Teracube 2e (emerald). I thought to check on an old Samsung S5 I used to test /e/ OS, fortunately on almost same version (1.7 R Dev), and got the same thing.
Fortunately too, I had TWRP and tried to wipe cache partition in order to solve something else → it solved this battery usage pb

So I will probably have to change recovery of Teracube to put TWRP. I won’t have much time to try now although.