No data transfer to PC possible

I can’t drag my photos from Galaxy S8 to PC. It used to work. The error occurs on multiple PCs and different data cables. The USB option “USB Data Transfer” is of course always adjusted accordingly.

I’ve been using Android /e/ for several years and it always works.

Thank you.

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

Which error exactly?
Are the files visible to the computer and an error occurs while copying them, or are the files not visible to the computer at all?
Which OS are you using on the computer(s)?

Do you mean the setting which you can access via the notification when the phone gets connected, or the often mentioned connection mode preference setting in the Developer options?

The photos are not visible. The Galaxy S8 is not recognized as a storage device, despite the manual setting “Allow data transfer”.

By correct setting I mean the settings after plugging in the data cable. I’ve never touched the settings in the developer options (debugging, etc.).

I will buy a new data cable tomorrow to rule out a technical defect (I had tried two older ones).

Tried everything again and again with Windows 8.1/10/11, unfortunately in vain.