No GPS + looping startup on Sony XPERIA XA2 (H3113)


I spent one entire day to try a fresh install by following the documentation and I would like to report two critical issues with this device :

  • None of the e-recovery provided worked (i tried with the 3 latest versions) and each one them provoked a looping startup after flashing with fastboot (the device start, show Sony logo and then reboot). Only TWRP was working correctly and let me proceed the next step of the installation.

  • GPS never worked and sometimes phone network wasn’t working too (i tried 7 time to install, 6 times with Android Q and one with Android R). At every installation i reinstalled the original version to restore firmware and i checked that firmware was working properly before trying a new installation of /e/. Each restoration was done from Windows 10 with the official Sony tool called “Emma” and the Android version is based on Pie.

All installation were made on Windows 10 with ADB + Fastboot + Google Android Driver, no error occured on the computer when flashing or sideloading files.

List of the versions tested :


In the end of the day, i was so bored that i reinstalled the original OS and kept it. All hardware is working fine (GPS is very reactive).

Maybe the documentation is obsolete ?

Can someone explain what is happening with firmwares when we install /e/ ? How can the GPS be so reactive on its original OS and then being completely disabled with /e/ ?