No mobile data LTE/TDSCDMA/CDMA/EvDo/GSM/WCDMA does not exist?

Life saver, i just flashed my Nexus 6 with E and there was no data connection, Canada on the Fido network. Using your code i went into the Phone Info menu and switched Network type to LTE/WCDMA which made Internet work on LTE. Thank you!

Thanks smu44,

I did a search online for correct “APN settings” for my phone carrier and followed the instructions on how to edit them. (lucky there is a reset default settings option ;))

Unfortunately, The new/edited APN setting always disappeared after I saved them. I eventually found out that this was happening, because my “APN enable/disable” option is greyed out, or rather blocked by my phone carrier. Apparently, the carrier does this so ‘novice users cannot edit APN settings without technical support’, hmmm. Big Brother, eh.

I will update this post when I get through to technical support at my telco. Btw, I will also confirm the “preferred network type” they use as well.


FYI, I clicked on the 3 dots at the top, next to ‘phone info’, and went into ‘select radio band’, when I attempted to select ‘Australia’. An error message said the attempt was unsuccessful. I then tried ‘Automatic’ and got the same error message.

Seems like your phone settings are being locked by your network provider, indeed :frowning:
If they don’t come back with a solution, we could try editing the APN settings file manually (it’s an XML) …

Thanks smu44,

I have not heard from my telco, yet.

I tried to do a factory reset with the sim card in, a few days ago, and my phone wouldn’t restart, so I connected it to the easy installer and restored eOS that way.

I just took my sim card out and tried another factory reset and eOS reset itself seamlessly?

I have come this far, if there is a manual work around I would like to try. I really enjoy using eOS.

It looks like you have some very special suppliers in your country ! :frowning:

We could try the manual method, but after reading your post I think that the changes may be overridden by your provider “lock” …
Are you aware of and comfortable with TWRP and ADB ?

Hi smu44,

I spoke to the technical support person assigned my case, today. (He did not receive my replies to his messages, but luckily called me anyway, hence the long delay?)

The technician confirmed that my Telco’s mobile data and my sim card were configured correctly (no errors on the Telco’s side).

The technician said that the problem (greyed out/blocked options) is because eOS has "not applied a patch correctly".

We tried some other tests like: “reset network settings” (reset WiFi, mobile, bluetooth in eOS), but when I tried to do this an error message appeared and I had to close the window: another blocked setting?

The technician’s advice was to update eOS, download a new setup file and reinstall it

I refreshed my updates and my phone was up to date:

Android 8.1.0
31 May 2021
Last checked: 26 July 2021 (1:39 pm)

I will try to reinstall eOS first.

If I still have problems, I would like to try the manual option you are suggesting, smu44. I know the Teamwin Recovery Project (TWRP) screen options and Android Debugging Bridge (ADB). I was in and out to them trying to get eOS installed - maybe, this is why I have these problems, lol? Honestly, I don’t know how I haven’t bricked my phone yet?

Btw the “preferred network type” is LTE only in Australia.
Also the APN settings were not correct, so I do need to edit them to be able to get mobile data.


With french LaPosteMobile (Virtual Phone Operator) my son suddenly lost data acces in may, with a Nokia7+/Android One. No more update since 05/25 one… (end of gg support ?)

No mater to solve issue, with the support (by phone) , new APN creation, config’ step by step OK, then new SIM…

The same SIM card, in a brand new Pixel 4a, works perfectly with a different (default) APN config’.

Will test ‘old’ phone with new APN…

1 Like

Stable build of /e/ for S9 are getting stuck at Oreo, that’s a shame :frowning:
You could try a Q “dev” build, as I read it works fine for some users; but AFAIK it can’t be installed by EasyInstaller, only manually (Install /e/ on a Samsung Galaxy S9 - “starlte”).

However, as @trefix stated, an old Android level should not prevent your device from working properly …
So we should try the manual APN setting, I’ll come back with a tested method ASAP (I hope, later today).

Thanks smu44,

I will wait for your reply and try the manual fix.

I am rereading the manual installation steps now, trying to get a better understanding of everything. I feel confident I will be able to work instructions out…eventually.

With illustrations

Thanks Pietro,

I am using Windows 10?

Hmmm, does this mean the Linux version of eOS is the one I will need to install to fix my corrupted handset?

Basically I will have to partition my hard drive and install a Linux OS to do this, right?

No mandatory,
both OSes, Linux, MacOS, and Windows (Odin), works to install TWRP on your device.

When you have TWRP installed, you can easily install what system you want

Sorry for the late reply, I had to conduct some testings and try to figure out if it will work with Oreo …

I’m pretty confident this will work, and I tried to keep it easy :

  1. take some screenshots of your current settings, just in case …
  2. reboot device to TWRP Recovery, then mount System read-write
  3. from computer, issue a adb pull /system/etc/apns-conf.xml to get the conf file
  5. still on computer, open the file with a good text editor (I used Notepad++)
  6. locate the line of your APN (warning : you may have several lines with the same APN name, but different settings; you’ll have to pick the right one …)
  7. as you wish, either copy the line with a new not-so-fancy APN name, or modify it directly
    a. please respect the case ! for example SPN for MNVO is upper-case in Android screen display, but it is lower-case in xml file; take a look a others lines as an example
    b. if you need to insert a new parameter, you may want to check others lines for it’s place (order)
    c. I found that “protocol” & “roaming_protocol” are useless if using only IPv4
  8. save the file, respecting the Unix format (EOL LF only)
  9. put back the conf file to the phone using adb push apns-conf.xml /system/etc/, unmount System from within TWRP
  10. issue a adb reboot system
  11. once started, go to your existing APN settings, use 3-dot menu, then “Reset…”
  12. (you may have to select your APN in the list) check that APN settings are correct
  13. I’ve found that, sometime, it may help to switch to WiFi, deactivate mobile data, and then deactivate WiFi and activate mobile data
  14. if you have a “user not authorized …” or similar message, your APN conf file may have a syntax error; please post it here by any way you like
  15. if you want to revert to your original file, reboot to TWRP and repeat the steps from 9 to 12 with the backup file

As a side note, you may want to read or backup your running APN settings while in TWRP Recovery, unfortunately it has moved several times with the different Android versions :frowning:
A good guide is available here : root access - Where are APN configs saved in Android? - Android Enthusiasts Stack Exchange
For information, for my encrypted Pie testing device it was is /data/user_de/0/ (SQLite3), I think that for an Oreo device you can find it in /data/data/­ml
(you will have to mount Data partition if not already).

You can try several settings as long as you with, it’s harmless.
Please remember to hit the “Reset…” in 3-dot menu each time you push a new XML file :wink:

I hope it will help solve your problem !

1 Like

Okay, here is my update … error 7!!!

I installed eOS with the easy installer, because I could not understand the meaning of terms like: 'flashing, ROM, boot, reboot" and how to use command prompts etc. (btw, I’ve worked out, with command prompts you have to be in the admin profile of your PC)

So, here I am, I have eOS installed, but mms and mobile data don’t work. Because I used the TWRP to install eOS via the easy-installer. I felt I had enough understanding to try piero’s option:

8) Install /e/ without computer from your device, with TWRP using the SDcard method

As is my luck, my TWRP is version 3.2.3-0 and I got error 7 when I tried to install eOS ‘dev’.

Now, my situation has changed a bit, lol. I have wiped eOS from my phone and need to change my version of TWRP to 3.3.

I have located TWRP 3.3 and downloaded it, but how do I install it?

Do I have to manually reinstall Samsung OS and then manually install eOS with the TWRP 3.3 and dev eOS?

Thanks for your patience and help everyone … I’m on a really steep learning curve.

For the definitions, this might help:

Basically, in this particular context:
flashing - installing something other than what was there before
ROM - Read Only Memory, originally, but now just means a different version of the OS (custom, stock, original, etc.)
boot - start, turn on
reboot- restart, turn off, then on again

Installing a new TWRP is just overwriting the previous, the initial installation instructions apply.

if you want to change TWRP version, simply use the TWRP install feature to install the new version.

Hi Taurus, Smu44 and piero,

Taurus, your explanations in ‘normal speak’ really helped me workout more of what piero and Smu44 where talking about, and find instructions that helped me fixed the problem.

I used Anonyme’s, easy eOS manual install with Windows Odin intsructions and was able to install different versions of TWRP and ‘dev’ eOS. Unfortunately, I still kept getting “error 7”

After exhausting the TWRP/dev eOS options I decided to download the easy-installer and install eOS onto my phone agian, and then try to work through Smu44’s instructions, if I had too. Thankfully, my phone started working properly with the fresh install via the easy-installer, phew!

Anonyme’s instructions are brilliant and very easy to work through. I finally understand what Odin is and didn’t have to use command prompts to install eOS manually.

Thank you, thank you, thank you!


Nice to read you sorted it out easily ! :slight_smile:

1 Like