No OTA updates since e-0.8-n-20200413

Hi everyone,
After waiting some week to see a new update, I decided to take a look at the available ZIPs for my oneplus3 and found out that I’ve been missing 3 updates since the last actually installed on my phone.

I tried several times to update using the OTA updater, but without success.
So, I tried to download the release and flash it from TWRP 3.3.1-1, but the installation fails because it cannot perform the upgrade on an ext4 data partition.
That’s the exact message it prints:

detected filesystem ext4 for /dev/block/bootdevice/by-name/system
Can't install this package on top of incompatible data. Please try another package or run a factory reset

I tried with:

same result with all of them.

Now, before I surrender to the idea of formatting my data partition, is anything else I could try to fix this?

Thanks in advance for your answers.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

make a backup of /data and store it on external SD or PC.
Format data
reboot in TWRP
push (e-0.9nxxxx) to your device
flash it via TWRP
if everything works fine, you can restore your data

I hoped to avoid this solution, but I guess it’s the fastest one to be applied.