No permission to upload or create files on external storage

Dear /e/-Team,

I have upgraded my self-hosted ecloud to the newest version ( according to the upgrade-guide provided. Everything went well and smoothly, except that suddenly I can’t upload or create files in an external storage, no matter if it’s via WebDAV or SFTP. I can access the files and open them, but obviously there are no writing rights. I also installed self-hosted from scratch following the instructions to rule out that it has something to do with the upgrade, but with the same result. I can access external storage, but I can’t add new files.
I also get the error message “External storage [name] is full, files cannot be updated or synced anymore!”. Probably the system cannot assess the correct storage size.
Hope you can resolve this issue soon, as the new design is really awsome an I look forward to using it as my daily go-to-site.

Kind regards,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Who is the provider for your external storage?

It’s a Hetzner Storage Box connected via sftp, but the error message also appears for my WebDAV connected hidrive from Strato. Interestingly I found out that this doesn’t happen when I connect to another Nextcloud but when the other Nextcloud itself is connected to an external storage vie sftp or webdav, I can’t access those folders as well.

You will need additional information here…

I suggest using 2 different browsers: one with you user account, one with your administrator (ncadmin) account.

On the administrator session, you may watch logs with either:

  • Settings/Logging with Log Reader app enabled (use F5 to refresh)
  • in a Linux shell cd /mnt/repo-base then docker-compose exec -T --user www-data nextcloud php occ log:watch -v (increase the number of “v”, up to 3, if needed)

Then retry access within the user session…

Also, what gives a docker-compose exec -T --user www-data nextcloud php occ files:scan --all ?

I get the error: Can’t get app storage, app files_external, user not logged in

What happen if you connect to Hetzner Storage Box from your host server, using the authentication you setup in NextCloud ?

Connecting with "mount.cifs -o user=<username>,pass=<password> //<username> /PATH/FOLDER" works just fine with writing permissions. Didn't try WebDAV, but I assume it would work too if connected directly

So it’s confirmed to be a NextCloud problem :confused:
Maybe something changed…

Is this other NextCloud also 22.x ?

No, the other Nextcloud is 25.

Anyway, I played around with several versions from the infra releases page and the issue begins with begins with “ecloud-”. "ecloud- worked well.##

Sorry, at this point I have some trouble understanding your problem :frowning:

You wrote:

And tried to access from host with CIFS: it is explicitly written in self-hosted NC Settings that ““smbclient” is not installed. Mounting of “SMB/CIFS”, “SMB/CIFS using OC login” is not possible. Please ask your system administrator to install it.”. So if your tried to mount with CIFS within self-hosted NextCloud it won’t work, at all. Or you should replay the test from host, using the same protocol (SFTP, WebDAV) as NextCloud.


So, it is not a /e/ self-hosted NextCloud instance, right? Then you may have a general issue with your foreign volumes. Or there is a bug in NextCloud, not relevant to /e/ or Murena.

This is a quite old release, not intended to be used as self-hosted. What’s in your docker-compose.yml file for NextCloud? It should be:

    container_name: nextcloud

OK, I can reproduce the problem with a Hetzner SB11 and SFTP, from a NC22 selfhosted.
Working on it…

Did some research in Nextcloud Community forum and Github: this is a known problem, but no solution came right to my eyes.
For example, see Add "no free space checking" in external storages configuration · Issue #18552 · nextcloud/server · GitHub (I couldn’t get this fix to work with NC22 or 23).
So this is not a real problem, only Nextcloud can’t get available free size and defaults to this message.

Here is the good news: as I could read everywhere, this is just a “cosmetic” warning and everything works fine! :smiley_cat: I could work with some files, as there is no error, just an annoying pop-up.