No Wi-Fi-connection on Samsung Galaxy SIII GT-I9300


I have a Samsung Galaxy SIII GT-I9300 with a fresh installed /e/OS (e-0.19-n-20211023142427-dev-i9300). TWRP is version twrp-3.6.0_9-0-i9300.

Installation worked without any problems, everything’s fine but the Wi-Fi: the device shows all available Wi-Fi-spots, but will not connect. Tried it with several spots.

The same behaviour as in the previous /e/-version. And as I remember with DivestOS. So, I don’t think it’s a specific /e/ problem, but maybe someone here knows a solution. I can’t find any helpful ideas in the net.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Has anyone an idea?


Just installed same versions you mentioned and connected directly to my 5 Ghz WiFi. There seems to be a problem with your device/the software/your procedures or your router.

I am a little surprised to see you using TWRP 3.6 with Nougat. I think the install documentation mentions a contemporary TWRP. Either that or the /e/ recovery might give a better result?

I used twrp v3.6, it works.

1 Like

Hey Doppel-D,

thanks for your reply.

I think, that the software, my procedures and the router are ok. The problem exists with every fitting lineageos-based operating system. I have some experience in installing custom roms on several devices, so, I think there should be no mistake. The router delivers internet connection for about 15 different devices: it works properly.

By now I suppose a hardware deffect. :frowning:


Hey aibd,

thanks for your reply.

No, in the documentation they mention and link the twrp, that I use: Install /e/ on a Samsung Galaxy S III (International) - “i9300”

Is there a /e/ recovery for the SIII GT-I9300?


Hi @sunny-bearcliff, you have the confirmation from @Doppel-D so my suggestion sounds like a side issue. I really only mentioned it as you bumped your thread and I had noticed that at first reading. (No, I do not see a linked /e/ Recovery; further side issue, the good thing going for /e/ recovery, when available, is that it is built for that device and Android version.)

  • It is interesting that you point out that /e/ documentation points to “TWRP - latest”.
  • TWRP is known to be (partially?) version specific (more tolerant in some cases more than others, it seems).
  • Install LineageOS on i9300 | LineageOS Wiki points to “TWRP - version” (in fact twrp-3.2.3-0-i9300.img).
  • We see mentioned in /e/ documentation “The version of TWRP we used to test the ROM was”
1 Like

@ aibd,

thanks for your suggestion.

I have nothing to loose: I will give TWRP a try, but without any expectations. :wink: As I wrote: Wi-Fi did not work with several custom roms (for ReplicantOS that’s normal :smile: )

Lucky me, the device is just for learning and testing. It’s not my daily driver.

1 Like