Not able to log on wifi with / in the passcode

I have a FP3 with e OS 0.23 installed. It works fine so far. When I tried to log on to the wifi at home via QR code, it did not work, as there was a problem with the passcode. I checked if there is a problem with the QR code, but non-e-devices were working fine.

I checked the passcode and realised there are special characters. Whilst “,”, “+” and “#” seem to go through without problems, e OS obviously cannot handle “/” in the passcode.

Is this a known bug or am I doing something wrong?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I don’t know (passcodes are tricky to “correct” !), but if you were to treat it as a bug, how exactly can you demonstrate one special character is being ejected?

… or are you asking in relation to the QR code? I can imagine the QR generating unknown errors, however.

I use Binary eye.

Well, I used the trial-and-error method: I changed the passcode on my router several times, creating new QR codes each time, and it was working in all variants as long as there was no / in the passcode. As soon it was there, e OS did not connect via QR code (I did not try typing the passcode manually, so the bug might be either in the code reading out the QR code or in the actual wifi-connect-code).

Thanks for clarifying.

What would I have to do to get this issue fixed? Is it reported somewhere already or can I report it myself (or does this thread count as a report)?

1 Like

Thank you, but if I try to register there, it tells me:

1 error prohibited this user from being saved: Email is not allowed for sign-up. Please use your regular email address. Check with your administrator.

– I do not know what’s wrong about my address, I’m using the same address that has been working here. So I won’t be able to report that bug.

GitLab registration has been partially disabled to avoid spammers :frowning:
Please write to

Edit : it is documented : Report an issue


Thank you, now it worked!

If anybody comes across this problem, too, cf. this: Not able to log on wifi with / in the passcode (#5344) · Issues · e / Backlog · GitLab