OBDLink app unable to load add-ons

The OBDLink app installed through Aurora for my OBDLink MX+ Bluetooth OBD adapter is unable to load enhanced add-ons:

Despite the message, the internet connection is working on the phone, and elsewhere in the app it succeeds in checking for firmware updates for the OBD adapter.

I tried adding a google account in microg and verified that it shows up in Settings > Accounts. I also tried signing into Aurora with my google account instead of anonymously, and uninstalled/reinstalled the app.

For context, this app is for use with OBD scan tools from this manufacturer. There are add-ons that are downloadable for enhanced capabilities such as manufacturer-specific codes. These add-ons may be in-app purchases for some scan tools, but they are free for the MX+ device that I have.

Any suggestions on how to get OBDLink working? It is one of the primary uses of this device, and Iā€™m willing to put some time and effort into it.

EDIT: It appears the Google Play store is required for paid apps, or presumably apps that involve payment, license validation, etc. Is this still true today? And if so, what is the best way to get it without downloading random files on the internet?

MicroG comes with two replacements for the Play Store. FakeStore is an app that fakes the existence of the Play Store to make apps happy but provides no actual store implementation. [BlankStore][blankstore] provides a partial implementation for downloading free apps but does not support paid apps, paying for apps, or validating purchases. Only the official Play Store allows for that, and it does work with microG.


1 Like

Solved, by installing a patched Play Store supporting (in-)app purchases.

It can be applied
manually: https://gitlab.com/Nanolx/microg-phonesky-iap-support
or with the NanoDroid package: https://gitlab.com/Nanolx/NanoDroid


This topic was automatically closed after 60 days. New replies are no longer allowed.