OEM Unlock setting not found in e/OS


I’ve just installed e/OS to have a very quick look and compare with other privacy oriented ROMs.

Now I’m trying to reflash my Galaxy S9 with another recovery ROM (Iodé for instance) to also have a quick tour and compare the look-and-feel. But I cannot find the “OEM Unlock” in the e/OS settings…

Where can I find this setting, and if not available what would be the workaround?

Thank you!

This is normal, custom ROMs usually lack that option and your bootloader is already unlocked. Skip this and proceed with the next step.

1 Like

Thank you! That’s strange, because if I try a “heimdall flash --RECOVERY image_name.img” command in download mode, it then reboots in standard mode, as if there was nothing written.

And if I had the " --no-reboot", I cannot reboot in recovery mode to avoid loosing the temporary wirte (I may be missing the good gesture/timing with my Galaxy S9)

Perhaps I miss something?

You have TWRP already from your /e/ install?

If you reflash a Recovery, you won’t see much happen. If the Recovery is “NEW”, you would expect to be able to recognise the change when you boot into “NEW” Recovery.

If you reflash a same Recovery nothing changes.

The whole Samsung “timing” thing only applies till you “dismiss” Samsung/Android (again, already done) !

Sorry I’m pretty new in all this, so not sure my terms are correct.

I have the /e/ recovery (from 1.2 download), it does not look like TWRP (except if the design has fully changed compared to the many screenshot I’ve seen in my searches).

On my recovery it’s written Version 3.1 (20220726)

So if my device is now unlocked, let say I want to install a TWRP or Iodé recovery : how should I proceed? Start in recovery first? Then “Apply update”, or maybe “Advanced > Enter fastboot”?

Ok, there is no “install” option on this recovery (unlike in TWRP), so maybe should I go back to “Download mode”, and push the new recovery through? But in that case if I understood well it’s not persistent and it shoud be immediately booted in Recovery mode…

How to do this on my S9? (I can only boot in standard mode with VOL DOWN+POWER, other options does not work)

So you need to be sure you can reach the other 2 bootable modes at will. From the foot of Info about Samsung Galaxy S9 - starlte

Recovery :
With the device powered off - hold Volume Up + Bixby + Power.
When the blue text appears, release the buttons.
Download :
With the device powered off - hold Volume Down + Bixby + Power.

In my first reply I did not guess that you had an /e/ Recovery! :blush:

So the method you should be using from Download mode is described on this page Install /e/ on a Samsung Galaxy S9 - “starlte” – the heimdall command you quoted above.

heimdall flash --RECOVERY /path/to/recoveryfilename.img

--no-reboot is totally optional now.

But in that case if I understood well it’s not persistent and it should be immediately booted in Recovery mode…

Now that you have liberated the phone from Samsung/Android, your TWRP Recovery is expected to overwrite the /e/ Recovery with no difficulty or special tricks!

You might, optionally, test that you have proper communication with the device in Download mode with

heimdall print-pit

If the device reboots, Heimdall is installed and working properly.

Ok I finally found the right way on my Galaxy S9!

The heimdall test (print-pit) + flash command (progress bar + messages) was OK, so I tried with a TRWP img (to doucle check with a different img), and without the " “–no-reboot” option, and when the device reboots it does not boot in the recovery mode (means the uploaded img is then lost)

And I finally found the correct procedure.

  1. Shut Down the phone, disconnect the USB cable
  2. Go in download mode (“Bixby key” + “Vol. Down” + “Power”)
  3. Plug the USB cable, then “Vol. Up” button to continue
  4. Execute the flash, with “heimdall flash --RECOVERY image.img --no-reboot” (–no-reboot is important to have more time for next steps, but I guess you can do without).
  5. Wait for the progress bar to complete (and heimdall to exit)
  6. Disconnect the USB cable
  7. Press simultaneously the “Bixby key” + “Vol. Down” + “Power” (instead of only “Vol. Down” + “Power” as described on the phone)
  8. The tricky part : at the precise moment the screen becomes black, immediately release the “Vol.Down” button and press the “Bixby key” + “Vol. UP” + “Power” buttons during 10 to 15 sec to enter the recovery mode

If it didn`t worked, redo the steps from 1. more careful this time.

It does not matter as you solved your problem, which is the desired outcome, … but in your case now, that logic is false!

Had you asked for reboot or rebooted yourself (immaterial) the device would boot to system. (Reboot really means reboot to system).

However, as the flash was successful, you might have been able to enjoy reboot to system … then, at your leisure boot to recovery, and find the replaced Recovery.

Believe me or not, but I tried and tried again. It perfectly worked when I flashed with heimdall from my stock S9 to /e/ recovery, removing the “–no-reboot” made the device reboot in recovery mode… (and with /e/ recovery it booted only on os if auto-reboot)

I may have a clue… While cleaning up some recovery images from my drive, I just realize that the /e/ recovery I was using (and flashed OK) while having this issue was a star2lte recovery (S9+) and not starlte.img (S9) : could it have created this behavior?