On my new /e/ Nord - "Trebuchet keeps stopping" on the "Recent Apps" button

I bought a new /e/ Nord, received it about 2 weeks ago, all good. I’ve been gradually “moving in”, transferring accounts, adding apps, customizing, yada. No problems.

I switched out the default Bliss launcher for my preferred Zim launcher … I tried Bliss again (this is my 2nd /e/ phone), but I can’t get used to it. At any rate, the phone has been working fine with Zim for over a week, no issues.

Today, I finally added the SIM cards (2 SIMs) … and now, the “Recent Apps” button has quit working, throwing up this “Trebuchet keeps stopping” error message. “App info” takes me to the app details screen … I have tried “Force stop”, then “Clear data” & “Clear cache” and reboot, but no luck. Not sure what else to do.

I can’t be sure that adding the SIMs was the problem … that required a reboot, and it’s possible something I added/changed earlier set up the issue, and the after-SIMs reboot triggered it.

Any suggestions? Danke, y gracias.

Just in case it helps throw any light, I think Trebuchet was added to /e/ in order to provide the ‘horizontal scrolling’ of Recent apps which we now see in /e/. I have no explanation for this behaviour though. :slight_smile:

I mean, I definitely do want that “Recent apps” button to work … but if that’s the only consequence, it’s just an inconvenience.

it’s a pity that on the “app has stopped / keeps stopping” there’s not 3rd button to show the exception on screen, because most of the time it is a good hunch to its cause. My wild guess - one of the apps it tries to list in recent apps is some kind of “on null” exception with an entry bringing it down. if you’re the interogating type, you could install adb, enable developer options (7x about phone touch), attach usb and look at the logcat while you reproduce the crash condition.

This morning at 5:00, the “Recent Apps” button was still broken, throwing the “Trebuchet” error message. At 5:45, it was working again. I didn’t do anything to fix it … a video chat with a friend and some web surfing, and magically, it started working again.

what /e/ version are you on? (at best with timestamp like: /e/-0.19-q-20211008… )

0.19-20211027142972 … this is still the version that came on the phone, from the /e/Shop … no new updates yet.

You may have filled the “Recent Apps” list with something :wink:

I want to reproduce, but where is the “Recent Apps button” in the ZIM Launcher?

For me, it’s in the bottom-right corner, the white square.

But unfortunately, I have no idea how to cause it, nor how to reproduce it. Like I said originally, I (very) tentatively felt like adding SIM cards to the phone triggered it, but that kind of just smells like a coincidence. More likely, I did something else days earlier, and it needed a hard reboot to trigger the issue.


ah thanks, didn’t think of those 3 buttons. I opened some Apps, used the recent-apps button, of course I’m missing what is triggering the bug. I think for you to get familiar with adb logcat is the best approach, it will show the reason of the exception

1 Like

Just a quick follow-up note … after a week and a half, and several more apps installed, several more hard reboots, etc … my “Recent Apps” button is still working correctly (along with everything else). IDK what the bug was, but it seems to have resolved itself.


On my /e/ OS 0.20 (Android 10, Fairphone 3) the Trebuchet-App also kept stopping like 10 days ago. I deactivated the app and updated to /e/ OS 0.21 two days ago. After the update, the “recent” button was still without function.
In the system settings, I chose “Apps and notifications” → “Show all apps” and then switched to “Show system apps” in the three-dots-menu (top right positioned). There I filtered for trebuchet, cleared the cache of the app and activated it again. Now it seems to work again. Maybe this is helping someone with a similar problem.


Hi, I had the same problem as Rainbird after a major update (from Oreo to Q on a S9 from the /e/ shop) except that I use Total Launcher. It turns out that Total launcher was not set as the default launcher anymore (and neither was Bliss). Setting it as default again fixed the issue.


Same issue when I upgraded my S9+ with os0.21-20220201158537, with CPL launcher.
Re-associate default launcher resolved the problem



That did it for me too. Thank you so much. Although the launcher rected normal it was not set as default. After doing so in settings/apps/standard/start everything works normal again. (Samsung s10e) Occured after system Update OTA.

1 Like

Same here. “recent apps” button stops working after installing different loader. I had this problem with the “Lawnchair” and “Launcher<3” loaders. They all crashed Trebuchet repeatedly. Disabling Trebuchet has the effect that “recent apps” button stops working. I’m on S9 /e/OS 0.22-20220226166118

Hi @jamesc welcome to the /e/ forum. Do you already have one of your “alternative” launchers set as the default launcher?

If yes, and you plan to stick with the alternative, please can you try to delete cache and delete app data for both Bliss and Trebuchet. (Trebuchet is already installed as a system app, so in Settings > Apps and notifications you will have to use “show system” in the top right 3 dot menu to find it.)

Thx @aibd. Your suggestion worked!
I reinstalled an alternative launcher (Shade Launcher). Recent apps button made Trebuchet crash.
But making Shade Launcher default (Home button - use Shade always) and then clearing the cache of the Bliss and Trebuchet apps as you indicated, made everything work perfectly!

BTW any suggestions on good Launchers, or discussion area on good launchers?

1 Like

Thank you Lars,
I was searching for YOUR solution since weeks! :pray: