OnePlus 6T – No OS Installed, says TWRP

Hi, I’m trying to install /e/ e-0.9-p-2020051454091-dev-fajita on my OnePlus 6T, but I’m unable to boot the system.

I have successfully installed TWRP permanently on it and sideloaded the latest version of /e/ but on reboot, the device actually goes in fastboot mode. At this point, if I reboot in Recovery Mode, the Lineage OS Recovery is showing up.

I sucessfully sideloaded TWRP again, but that doesn’t solve my issue. If I try to reboot the system from TWRP, it says “No OS Installed! Are you sure you wish to reboot?”.

I tried to follow the install guide as closely as possible, BTW. My OP6T was running Android Q. Is there anything I missed in the instructions/is that a problem to downgrade from Q to P ?

Hope someone can help here.
Thanks in advance !

Hej @marchottinger,
If the Lineage OS Recovery cannot be replaced by TWRP Recovery, only the Android Recovery with stockROM Android OxygenOS helps to flash.

On this occasion I would immediately wind up Android OxygenOS 9-Pie. Then /e/ OS 9-Pie is guaranteed to have no compatibility problems.

1 Like

Hi, thanks for your quick reply. The installation of /e/ seems to work correctly and I can replace the Lineage OS Recovery with TWRP Recovery by sideloading it from Lineage OS Recovery.

But it seems to be impossible to boot /e/ because it is not recognised as a bootable OS.

I suspect the issue is the downgrade from Q to P, but I don’t see why it would be problematic. Looking for a workaround right now. As a last resort, I could use the msmdownloadtool to factory reset my OP6T to OxygenOS 9, but I don’t have a Windows computer at home.

Hi @marchottinger,

Have you tried to boot or not ?
No OS installed is an usual fake error message from TWRP, some users don’t care about it and successfully boot to /e/OS


Hi @piero, yes I tried to boot, but my phone directly goes into fastboot mode.

Others OnePlus 6 similar topics

The problem will not so much be Q or Pie but rather the specifics of an a/b device.

Please follow these TWRP Install Instructions for the OnePlus 6T

@archje Thanks, I’ll try that tomorrow morning…

Hi, I tried the “official” way to install TWRP, and it works as expected. TWRP seems to work flawelessly and I know how to install it “permanently”.

Problem is apparently, I don’t know how to install /e/ the proper way, because it doesn’t boot, even though I follow carefully the /e/ installation guide for fajita.

You have two slot for booting…
Have you read all the Others OnePlus 6 similar topics ?

Please make sure that TWRP Recovery has switched to the active slot before installing /e/ OS ROM.

1 Like

Yes, I read the instructions and tried to switch between slots with TWRP. Maybe I should first set slot B, then install /e/ by sideloading it. I don’t think I’ve tried that particular setup.

EDIT: I tried to fastboot --set-active=b then fastboot reboot-recovery and my device doesn’t reboot.

EDIT 2: If I try to switch slots in TWRP, it says in the log ‘Unable to mount storage’. Maybe that’s the root issue here ?

I also get an error when sideloading /e/ : "Unable to find partition for path '/cache'". I’m a bit confused about that. A directory named “cache” is at the root of the file system. There’s maybe a permission problem ?

EDIT: is it also possible to install /e/ directly from TWRP using the install feature from a usb key ?

The /e/ OS ROM zip-file can not only be installed via sideload, but also with TWRP.

In TWRP, the command INSTALL can be used to install files with the extensions .ZIP or .IMG from the internal storage of the device, from the USB OTG or microSD card.

1 Like

Yes, for sure, this is possible. I have flashed /e/ on several other devices this way.

Just for your information, you are not alone in this case.
I got in this exact same situation. I rolled back to the stock ROM, because I need to be able to use my phone to work from home, but I’m reading stuff here and there to try find a solution.

Please make sure that TWRP Recovery has switched to the active slot before installing /e/ OS ROM.

Could you, please, give us more information about this? For what I’ve read, a/b partitioning seems to be a pain in the ass. Do you mean we should try installing TWRP, then go to slot B, then install /e/ OS, and finally try to reboot?

Thanks a lot!

I’ve found a really easy solution that I will detail in a few hours.
I sideloaded Oxygen OS 9, then flashed /e/ and it worked straight away. Problem is one need to find from a “reputable source” the OTA or full ROM.
I would like to thank @piero @archje @donut3 for their support.

I will describe more precisely what I’ve done later on.

1 Like

I thought I tried this, but I must have been wrong since it didn’t work for me…
Looking forward to be able to read your how-to!

Thanks a lot for your hard work!

/e/ on fajita how-to 2020-05-27

---- first step - adb & fastboot “installation” ----

NOTE: The following instructions describe the necessary steps for Mac or Linux users using a bash (or other) terminal.

Go to the Android SDK Platform Tools download page.

Download the SDK Platform-Tools for your specific OS.
The zip file contains adb and fastboot.

and a bunch of other utilities.

Place the contents of the zip file in a suitable location in your computer.

Using the Terminal, edit your .bash_profile or .bashrc to add the Android SDK Platform Tools to your PATH like so:

if [ -d "$HOME/your-path-to-platform-tools" ] ; then
    export PATH="$HOME/your-path-to-platform-tools:$PATH"

open-up a new terminal OR execute the following command:

source .bash_profile or source .bashrc , depending on the file previously edited.

---- second step - test the Android SDK Platform Tools ----

First, enable developper options by tapping a number of times on the Build Number of your OS. You can find that field in the Settings app of Android in the “About Phone” section (name may differ on your specific OS).

You will see a message saying “You are now a developper!”

Then, enable USB debugging on your phone and OEM unlock in the Developper options.

Connect your Smartphone to your computer and issue that command :

adb devices

if your device is recognized, you will see at least those two lines (hex code + device):

List of devices attached
****13dc	device

If everything went well, then proceed and restart your phone in fastboot mode.
There are ways to manually reboot in this mode. I will show how to do that using adb, because you need the Android SDK Platform Tools to continue.

adb reboot bootloader

Then issue that command to check if fastboot works properly and your phone is recognized.

fastboot devices

if it works you will see the following output (hex code + fastboot):

****13dc fastboot

---- third step - unlock and reset your phone ----

You can now unlock your phone. Warning, your phone will be reset during this operation in order to protect your data. Please do a backup of your important data.

To unlock your phone :

First do a backup (learn more about “adb backup -apk -shared -all”)

Then issue that command:

fastboot oem unlock

Check if the phone is unlocked by issuing that command:

fastboot oem device-info

Reboot the device.

Re-enable the USB debugging as shown above.

Then reboot into fastboot mode to prepare your phone to temporarily boot on a custom recovery image.

adb reboot bootloader

---- fourth step - boot from TWRP ----

Now you can proceed by booting TWRP which you can download for fajita (OnePlus 6T) on that page:

Download at least the img file which you will boot to install /e/

Once downloaded, boot TWRP:

fastboot boot <recovery_filename>.img

TWRP will boot and you have options to use the “Install” option and install /e/ from and OTG usb cable and USB Key or sideload /e/ using the “Advanced” option.

---- fifth step - ev. downgrade your OS and install /e/ ----

If you are currently running Android Q you will maybe face the issue that /e/ will not boot no matter what.

I suggest you try and download a full or OTA ROM of Oxygen OS P and install or sideload it. The steps are the same as installing /e/ which will be described now:

Enable the sideload mode in TWRP in the “Advanced” option or use the “Install” option to install locally from your phone.

adb sideload <os_installer_filename>.zip

the zip file can be either Oxygen OS or /e/.
You can find /e/ for fajita there:

If all went well, the System should be bootable.

Reboot from TWRP and enjoy.

Useful link:

1 Like

Thanks so much !

I’ve made a step-by-step how-to of my /e/ installation. Hope it helps others facing the same problem.