OnePlus 8 Pro stuck to Fast Boot mode after /e/OS new release

Hi All,

I have two OnePlus 8 Pro mobile phones (IN2023) that I de-googled and installed /e/OS on after purchasing them new last year, following the official documentation.

For about 10 months, both phones worked flawlessly. However, after installing the June /e/OS update, both phones started rebooting into Fast Boot mode after a reboot request (see screenshot below):

The same issue occurs on both phones, so the likelihood of data corruption is almost zero.

I can eventually boot both phones by holding down the power button for 15 seconds after selecting RESTART from the Fast Boot mode menu, but this is not sustainable as I have to do it at every reboot. It’s also very annoying. Additionally, after a full successful reboot, the update appears not installed. When I try to install it again (and I’ve tried multiple times), the same issue occurs.

Interestingly, this problem started after /e/OS released version 2.

Any help or hints would be much appreciated.


Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

Pl check if the issue is similar to the one reported here. If it is the same you can add your comment to the same issue if facing issue with logging on GitLab check the response here