OnePlus 8 pro Troubleshoot unbrick, oem unlock, etc


I finally managed to install /e/OS on my OnePlus 8 pro, and that was kind of a challenge. I fell in some traps, so I write this troubleshoots guide. I didn’t know where to post it, so feel free to move it where it should be.

Hope it will help someone.

By the way, /e/ is awesome, never give up !

My device is bricked, only run fastboot or show the error message “has been destroyed” on startup. What can I do ?

Note: you will need a PC with Windows 8, 10 or 11, maybe several (not joking, I needed 2 PCs, you might need to socialize with other human beings and ask them to borrow their computer).

Important: your phone should be fully charged and be able to hold for at least 3 hours.

Oh, I almost forget: this will wipe your phone. Everything will be removed with no warning.

First, force shutdown your device:

  1. Unplug any cable.
  2. Hold volume up + power for 10 seconds.
  3. Release everything, wait for a few seconds. Your device should not reboot, it should be off. If it reboots, try again and release as soon as the screen turns off.

Now, download the MSM Tool for your device on [OP8PRO][OOS 11AA/BA/DA] Unbrick tool to restore your device to OxygenOS | XDA Forums (
:warning: Download the last Android 11 for your device, otherwise you won’t be able to install /e/

Unzip what you’ve downloaded.

Then enter into EDL mode:

  1. Hold volume up + volume down together. Keep holding them, do not touch anything else. Do not press the power button.
  2. Keep holding the buttons while plugging your phone to your PC. The screen should be black, nothing should happen (except the sound that windows emits when you plug something)

Now, start MSM Tool
3. Open MsmDownloadTool V4.0.exe
4. On the login window, change the user type to “Other”
5. As explained on the link above, select EU (if you have an european firmware) or O2 in the dropdown and click on Target.

Here, if your phone does not appear:

  1. Click on the Windows button in the task bar and type DEVICE
  2. Open the device manager
  3. If you see an unknown device called QHUSB_BULK, a driver is missing; if you don’t see your phone, either it is not pugged, either your cable is not able to transfer data, either your phone is not in EDL mode (it started, or it is off).

Anyway, if you don’t see your phone nor QHUSB_BULK, unplug it, power your phone off and redo the EDL steps.

If you need to install the driver:

  1. Open Microsoft Update Catalog and download the driver for your Windows version
  2. Extract the content of the .cab file
  3. In the device manager, right click on QHUSB_BULK and update the driver.
  4. Use the assistant to browse and import the driver you’ve extracted

Back to MSMTool:

  1. Your phone should appear. If not, power it off and start in EDL mode.
  2. Dropdown: EU or O2.
  3. Click on Target.
  4. Click on Start. Do NOT touch anything else. Do NOT use your computer. Your computer MUST NOT crash during the next minutes.
  5. If you have a religious or superstitious habit, this is the time to use it while it downloads a factory firmware to your phone.
  6. If the download was successful, your phone reboots with the original software. You now can install /e/OS with the Easy Installer.

Nah, of course it didn’t go THAT well for me ! I had a communication error. If it happens to you :

  • Change your USB cable
  • Try on another USB port
  • Try on a USB hub
  • Try on another PC (that was the only way for me, I had to use an old MacBook on which I had to install Windows !)

I cannot unlock the OEM, in the developer menu, the OEM unlock switch is gray and disabled. What should I do ?

I’ll assume that you already have activated the USB debugger option and your default USB mode is file transfer, as it is explained in the installer.

First, configure Wi-Fi or an internet connection. Close the settings app.

Then, download the Android Platform Tools and extract it.

Open a terminal. On Windows : click on the window button in the taskbar and type CMD. On macOS, open the application called “Terminal”. I won’t explain for Linux, you already use it every day.

Open with your file explorer the folder containing the Android Platform Tools. Drag the ADB file to your terminal. Its full path should appear in your terminal. Add a space and the following command :

shell pm disable-user com.qualcomm.qti.uim

It should look like : “C:\Users\Guy Tarembois\Downloads\plateform-tools\adb.exe” shell pm disable-user com.qualcomm.qti.uim

Press enter. The terminal should answer “Package com.qualcomm.qti.uim new state: disabled-user”. Otherwise, either it is off, either developper mode is off, either your cable cannot transfer data.

On your phone, open Settings, OEM Unlock should be available.

What the F### ?! /e/OS is buggy as hell, I cannot even set Wi-Fi ! F### this C### !

Calm down, /e/OS is too awesome to be buggy. You’ve just installed it over the wrong Android version. Do exactly as if your device was bricked, flash the original Android 11 with MSM (as explained above) and re-lunch the Easy Installer, everything should go be just fine.

How can I root my phone ?

Use Magisk and TWRP. This is the easiest way.

Be careful: many apps can detect rooted devices and refuse to open, efen if you use MagiskHide (which has been removed from the last version of Magisk).

How can I install TWRP ?

First, download TWRP.
Then, if you manage to do it, tell me how: I lost half a night and I soft-bricked my phone trying it. i given up, rooting seems to be kind of useless with the last versions of /e/OS.

Is there any way to have a good keyboard with gesture touch ?

This one is a hard one. I have tried a LOT of keyboards. I have tried AnySoft Keyboard, but gesture is not currently efficient for my language. Maybe it will for you.

I finally have found in a dark GitHub issue a fork of a fork of OpenBoard (which is a port of the AOSP keyboard without all the Google spying stuff) that supports gesture. You will find it on GitHub, repo erkserkserks/openboard.

Be careful, use it at your own risks, but this is the only decent way I know.

I am not sure to be able to answer requests, this is just a post to thank and help as I was helped here and on XDA-Developers dot com. Thanks for everything !


Links :

Hey raph,

i probably hardbricked my oneplus 8 pro. The screen is black, its not recognized in edl (was so before, when I already used your description).

Is there any hope? Or is my phone just dead and unrepairable?



I am so sorry !

I am sure you have already, but did you try to charge your phone several hours ?

Did you read the full thread here ?
Maybe someone there can help you.

Wish you the best !

Hoping that you get help at XDA, but meanwhile might it help to read the methods in different words

I am successfully installing /e/OS (Android R) over the MSM-flashed OxygenOS 11, but when I chose “reboot system now” in Recovery, all I get is “Orange mode”, and it ends up showing a fastboot screen which isn’t really fastboot, so I need to go back into edl and use MSM tool to unbrick again.

Never tried EasyInstaller though (not running SNAP packages on my Linux machine anyways), should that even work? Only heard bad stuff about that…

How do I prevent Orange Mode? The instructions mention flashing vbmeta and dtbo, but the download of those files is only available from an Android 13 version, not Android 11, so could that be the issue?

/e/OS documentation

Flashing additional partitions

  1. Download the following files from the directory named with the latest date here
  • dtbo.img
  • vbmeta.img
1 Like

If you wanted to eliminate that “potential mismatch” a method to create your own vbmeta and dtbo from the ROM you intend to install is given here OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #8 by bofh666.

1 Like

Yes, but the instructions forget to mention

So I guess for vbmeta and dtbo the android version mismatch doesn’t matter, since it does boot into /e/ recovery.

However, since the instructions omit copy-partitions, I didn’t do that. Which is probably the reason why I end up in “orange mode” and have to use windows and msm tool to revive the phone (twice now).
Last time I was in Windows, I gave easy installer a chance (which of course didn’t work, seemed to never send fastboot oem unlock command to the phone), but I saw it download which I know from the 10 or so OnePlus Nord phones as well as my own OP7T phone I’ve flashed with /e/OS so far.
Which may be the reason, so now I’m trying that step (sideloading it before the OS). In case this doesn’t work either, I’ll have to come back to ask: What else is missing in the instructions to get /e/OS running on the phone instead of soft bricking it each time?

Wouldn’t it be enough to find a flashable zip of the original OOS version the device is on and extract those files from there?
(Why aren’t they packaged correctly, anyways?)
OK, I’ll give it another try…

Hello Guys,
I had a GS290 and installed e/os so easy through the easy installer.

Now I bought a OnePlus 8Pro and its a pure headache.

I have been through greyed out OEM unlockers, Orange State, Qualcomm errors, only black screens and have reserected the phone via videos, installing tools upon tools and than finaly the easy installer was going up to the second boot — and than lost it installing eos.

Now the phone is stuck again in a loop between recovery and fastboot mode.
The phone wont start anymore.

It tries to boot twice and comes to a black screen with chinese words and under english, when i choose english it says: kindly reminder, system error, after select laanguage…

I say ok and come to the english menue RECOVERY with the options
format data (I did ),
reboot device (I did and land after 3 reboot tries again here)
Power Off (it does),
Boot reason (phenix_kernel_to_recovery),
Adavanced → Reboot to fastboot mode (with its options START, etc and i loop back to recovery mode) and Rebbot to recovery mode (which takes me back here)

In non of the states the easy installer recognizes the phone anymore and it just loops.

Has anybody been at this point and knows a way out?

Just to clarify, the main Bootloader is unstable, that is that it always leaves the bootloader in a loop ?

After the steps you have taken it would be understandable to have no bootable system nor recovery.

But if the bootloader is damaged you should probably consider to now use the method mentioned further up the thread to unbrick the phone with EDL and revert the phone to OOS.

I have oneplus 8 t-mobile current image boot recovery has been destroyed i try different different method boot my phone but not working any solution no foing to EDL mode