OnePlus 8T can't shutdown/touchscreen doesn't work

You are aware that is available in the meantime ?

And a new build should be along in the next few days :slight_smile:

You got me all excited. I’ve been watching the page like a hawk

That’s what I’m running now. I thought you meant a new build of /e/. :melting_face:

Hello, i’m testing /e/OS on many OnePlus devices.
Actually with the S build i encountered this bug with the Oneplus 8 IN2013 and the Oneplus7TPro HD1913. No touch screen with any S build.

Both working well with R stable build.

Hi all,
Any news on this topic?

So I was on lineageOS with Micro-g. I saw that /e/ had been updated to 13, so I followed the instructions to the letter and still had the same result. Recovery worked, flashed everything appropriately, and touch screen still doesn’t work. I might just go back to stock at this point.

1 Like

Anyone could help with this?

Has somebody tried the last /e/ v14 release ? is this bug fixed ?

1 Like

I may be able to test it tomorrow night. I will see. I am so busy that I barely have time to write this comment :sweat_smile:

Edit: for 8 Pro, not 8T

Hello, i updated my two phone : Oneplus 8 (instantnoodle) and the Oneplus 7T Pro (hotdog) with the 1.15 T build.
The touchscreen issue had fade with this update. I didn’t tryed the S build v 1.15 on those phone.

For the Oneplus 8 i used the S build recovery from e/OS but once boot on recovery touchscreen doesn’t work so i tryed to installed the lineageOS recovery and toiuchscreen worked and i could apply update to the T build that work fine.
For the Oneplus 7T pro e/OS recovery from S build worked fine.

T build work fine on Oneplus 5, 5T and 6T phone.

Tested S and T with OnePlus 8 Pro, coming from each version of OOS (Android 11, 12 and 13), and the touchscreen on eOS S and T did not work with any of them.

I got the T (dev) build to work on the guacamole (7 Pro) tonight after a lot of backtracking and spending a whole day staring at a non-working touchscreen after a fresh install of S (dev).

I believe the key is properly extracting & flashing the 2 image files (dtbo.img, vbmeta.img) referred to in this section of the manual install (e.g. on guacamole):

… according to this extraction method, and ensuring that the versions of these 2 additional partitions flashed are the same as the ones in the ZIP being installed:

All in all I went from a 7 Pro on stock OxygenOS 12 to /e/OS T (dev) by the following route:

  • revert OOS 12 to a stock OOS 11 using MSMDowloadTool
  • unlock the bootloader according to usual /e/OS instructions
  • install OxygenUpdater app to update firmware to OOS 12
  • extract & flash the 2 “additional” partitions from the T (dev) ZIP file payload as described above
  • download & flash the latest /e/OS recovery available for my device
  • sideload T (dev), reboot, and it’s done (working touchscreen + /e/OS Android 13). :heart_eyes:

I flashed the vbmeta.img and dtbo.img, both extracted from the payload from the T zip, on my 8 Pro before installing the T zip because I thought the same thing. It didn’t work. Touchscreen still not working.

I tired the same thing with S. Didn’t work on that, either.

One other thing I did differently in the procedure above which fixed the no-touchscreen problem for me:

There was a note in the /e/OS command-line upgrade instructions about Linux repositories’ fastboot being out of date so I wanted to ensure I was using the latest version. Compared to the repo version 29.0.6-debian I had from Ubuntu, there are some bug fixes in the latest 34.0.4 related to partition writing.

1 Like

Thank you for the respone! :blush: I’ll give it a go within the next week on my 8 Pro. I will also make sure both a and b partitions are flashed.

If it doesn’t work, I am giving up on eOS and the eOS/murena ecosystem, becuase that will be the 3rd or 4th time in a month that I have wiped my phone for eOS and I’m getting sick of restoring everything. Though, if it works, sometime in the next month I will write a python script to automate a complete backup whenever I plug the phone in. I can share it if I end up creating it and if anybody wants. But I am only doing this if it works this time lol. I am seriously over having to use MSM tool, then having to wait for firmware downloads and then upgrading the firmware, then flashing and sideloading, only to be met with a not working touchscreen :joy:

1 Like

Hey, how did it work in the end?

For the Oneplus 7T Pro, it is now working again:

This topic was automatically closed after 180 days. New replies are no longer allowed.