OnePlus 8T can't shutdown/touchscreen doesn't work

I backedup my phone and followed the instructions here ( to the letter. After rebooting the device per instructions, waiting a few minutes, the device restarted. The device functions…vibrates when I plug in/remove usb c. Pressing the power button turns off the screen. Holding the power button brings up the power menu, however the touchscreen doesn’t function so pressing shutdown is out. I’ve held the power button in for 30, 60, and 90s. I can’t get the device to restart or shutdown.

Update Today I learned that some OnePlus phones hard reboot button is vol up + power. So the issue is definitively the touchscreen. All the buttons work appropriately. The touchscreen worked prior to the flash, and it appears to be a software issue. When holding the power button down and the power button came up, one of the buttons was already highlighted.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

This behaviour has been seen and remains unresolved in these posts

And there is this open issue on Gitlab

Touchscreen does not work after command line install of /e/ OS S on hotdogb

Thanks. I was looking for the correct place to post the bug, so I’m glad it’s found. Is there a version that is known to work? for the 8T (kb2005)

The first link, the only one for kebab starts with

I updated my OnePlus 8T to Android 13 (the latest update), and installed

So the focus of the thread was in the Android version mismatch – that is /e/ must be installed on top of the same Android version stock ROM.

Answering your question, if it was a failure of the ROM, this was the version e-1.8.1-s-20230203257074-dev-kebab from Feb 2023 !

Can you rule out the Android version mismatch in your case ?

I believe I was on Android 13.

So I was able to confirm I was on Android 13. I was able to confirm the touch screen still worked via flashing Lineage 20/bootloader. Now I need to find a down grade guide. I’m really mad at myself because I saw the “Android 12” on the /e/ install guide but assumed it was just out of date instructions…and you know what they say about assuming. lol.

I will not try to give detailed advice, I do not have the phone, I have a OnePlus One from when things were simpler ! In my case I have the ROM and I can fastboot flash all (that is all partitons). Please treat a rollback from Android 13 as a specialist task and read carefully !

I suggest you study the advice given in the kebab thread I already linked.

If you find instructions you fully understand to use a fastboot flash method to rollback this is the nicest way to go (I have no bookmark of such method for this device). I did not fully investigate the advice here OnePlus 8T Touchscreen Doesn't Work After Install - #7 by descrato

My current knowledge does not extend beyond the advice I gave here OnePlus 8T Touchscreen Doesn't Work After Install - #9 by aibd.

Please be especially careful to understand this point OnePlus 8T Touchscreen Doesn't Work After Install - #15 by RdLr – your method of rollback must not leave any traces of Android 13 (or Lineage 20) in any partition.

Once you have done the rollback successfully, I would be inclined to give the phone an extended test on Oxygen maybe for a day or too – maybe over cautious !

Good luck


It is very cheeky and unorthodox to call for /e/ support in this way but, @marcdw, might you have a link to an Oxygen “Fastboot” ROM for OP8T which would be an improvement on what I have written so far ? Thank you. :slight_smile:

It has been awhile since I did anything with stock. For instance I wasn’t even sure if A12 firmware was available. Version labels confused me. A12 builds will have names like KB2005_11.C.11.

From what I gather, downgrading is only possible via the MSM unbrick tool. Requires Windows. Uses EDL mode. Bootloader can be locked or unlocked.
Seems it downgrades to A11 but not sure.
Last time I used a similar tool was when I converted from T-Mobile to EU firmware. Easy to use.

[OP8T][OOS KB05AA/BA/DA] Unbrick tool to restore your device to OxygenOS | XDA Forums

Fastboot ROMs are here. The OP mentions they cannot be used for downgrading / updating. Meant for restores or back-to-stock. Requires unlocked bootloader.
[ROM][STOCK][FASTBOOT] Stock OxygenOS Fastboot ROMs For OnePlus 8T | XDA Forums

Other than that I don’t have much.

1 Like

I may just have to wait until /e/ moves to a13. I don’t really feel like installing windows just to fix this. :*( I’m so mad at myself for messing this up so bad.

You are aware that is available in the meantime ?

And a new build should be along in the next few days :slight_smile:

You got me all excited. I’ve been watching the page like a hawk

That’s what I’m running now. I thought you meant a new build of /e/. :melting_face:

Hello, i’m testing /e/OS on many OnePlus devices.
Actually with the S build i encountered this bug with the Oneplus 8 IN2013 and the Oneplus7TPro HD1913. No touch screen with any S build.

Both working well with R stable build.

Hi all,
Any news on this topic?

So I was on lineageOS with Micro-g. I saw that /e/ had been updated to 13, so I followed the instructions to the letter and still had the same result. Recovery worked, flashed everything appropriately, and touch screen still doesn’t work. I might just go back to stock at this point.

1 Like

Anyone could help with this?

Has somebody tried the last /e/ v14 release ? is this bug fixed ?

1 Like

I may be able to test it tomorrow night. I will see. I am so busy that I barely have time to write this comment :sweat_smile:

Edit: for 8 Pro, not 8T