OnePlus 9 Pro: Flashboot into Recovery fails

Hi Fellows,

I can’t seem to boot into e.OS recovery or TWRP on a OnePlus 9 Pro (LE2123). For some reason both these recoveries do not start, instead they get stuck into the following “fastboot mode” screen (TWRP) or continue to boot into stock OOS instead (e.OS recovery).

Device Info:
Build OOS
Model LE2123
fastboot version 33.0.2-8557947

What I did was:

  1. OEM Unlock
  2. Reboot into Bootloader
  3. a) fastboot boot recovery-e-1.1-r-20220629200015-dev-lemonadep.img
  4. b) fastboot boot

Both failed as described above. I also reverted to stock using MsmDownloadTool V4.0.exe and pushed rev_OverSeas_210324_2236_release_OTA-BLOCK_Signed_fp2103242236_cve2021-03-01_ufs_Oxygen-OS- This gave the same OOS as when I had originally started out with. But the behavior when flash booting into recovery remained the same.

Would someone have an advice an what to try next?
On other posts here it is said to update to latest OOS v11. But before I try to put on, I would very much appreciate your advice. Many thanks.

I continued a little bit: I upgraded to via a full local update (using from XDA). So right now the device is on latest OOS

Unfortunately all recoveries do not start. The promptly continue to boot into the standard OS (which takes ages to startup after having tried to flashboot boot into recovery).

Would anyone have an idea on what to try next? I am a little clueless right now.

These are the recoveries I tried:

  • fastboot.exe boot .\
  • fastboot boot .\lineage-18.1-20220524-recovery-lemonadep.img
  • fastboot boot recovery-e-0.22-r-20220225165877-dev-lemonadep.img
  • fastboot boot recovery-e-0.23-r-20220324172928-dev-lemonadep.img
  • fastboot boot recovery-e-0.23-r-20220405175826-dev-lemonadep.img
  • fastboot boot recovery-e-1.0-r-20220527188878-dev-lemonadep.img
  • fastboot boot recovery-e-1.1-r-20220629200015-dev-lemonadep.img

Would greatly appreciate any recommendations. Thanks!

Hi, you’re suppose to flash recovery to boot, then use key combo to boot it

fastboot flash boot recoveryfilename.img

Manually reboot into recovery mode

With the device powered off
hold Volume Down + Power

Yes, absolutely correct. I tried to avoid that at first. In the past a “fastboot boot recovery.img” was sufficient to temporarily boot into recovery, see if it works (not wrecking it) and do what had to be done. I have had many reinstalls in the past because a “fastboot flash boot recovery.img” did break and required a reinstall afterwards.

So the “fastboot flash boot recoveryfilename.img” should maybe help? Which recovery image should I use to flash over the OOS

Many thanks!

I fastboot booted twrp on op9 last month over that same oos build.

fastboot boot twrp-3.6.2_11-0-lemonadep.img

The twrp.img, not the installer

1 Like

Oh my, I really tried to flash the twrp zip.

@chrisrg, you are a livesaver. Many thanks! TWRP Screen is smiling at me right now.

Nice one Olli, good luck!

For the record, on my LE2123 with OOS, only the following get me into recovery:

  • fastboot boot twrp-3.6.2_11-0-lemonadep.img

With both of these I had no luck getting into recovery, instead they start into OOS right away:

  • fastboot boot recovery-e-1.1-r-20220629200015-dev-lemonadep.img
  • fastboot boot lineage-18.1-20220524-recovery-lemonadep.img