OnePlus 9 Pro (LE2125) \ eOS & Lineage Boot Image Issue

Hi Guys,

I am struggling terribly with installing eOS… stuck at booting to the recovery image. I’ve tried several different flavors of boot images currently available and get jammed up at a boot screen every time (“unlocked bootloader” screen, 1+ Logo screen, Fastboot screen). Also tried using various flavors of TWRP. As soon as I flash dtbo.img, vendor_boot.img, and a recovery image… the phone is seemingly bricked until I reload things via EDL Mode and start from scratch.

The phones came with OOS 13 so I have been unbricking/downgrading using MSM Tools which loads OOS I update to OOS offline afterwards. Does anyone have the following eOS/Lineage “boot” files that works with this version of the stock ROM?

-corresponding recovery image

I’ll also take files that work for OOS 12 C.48 as an alternative as that is far as I can get in the Android 12 realm. Otherwise, will just wait for eOS “T”.

Thank you very much!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like


I finally found a way to get the device ROM to Android 12 C.66 which appears to be the latest prior to Android 13 hitting the scenes.

  1. Stock OOS Full Rom (via EDL Mode/MSMTools)
  2. OTA OOS Full Rom (via OS Local Update)
  3. OTA OOS Full Rom 12 C.48 (via OS Local Update)
  4. OTA OOS Full Rom 12 C.65 (via OnePlus “Local Update” utility)
  5. OTA OOS Incremental Rom 12 C.66 (via OnePlus "Local Update utility)

As exciting as that is for me… still having the issue described in my original post above using the last versions of the Lineage 19.1 dtbo.img and vendor_boot.img from 12/27/22. Specially, flash all 3 img files as instructed and manually reboot into Recovery only to be met with a perpetual 1+ Logo boot screen. It has to be something I am doing wrong or there is a step being missed. Scratching my head big time.

Let me know if anyone has any thoughts on this please.

1 Like

I’ve tried all dtbo.img and vendor_boot.img. This is the only that worked for me.

With and recovery-e-1.7-s-20230111250406-dev-lemonadep.img from /e/ image ROM download


That did the trick! I started fresh, updated all the way up to OOS 12 C.66, and followed the Install directions verbatim using the files you had linked.

Thank you very much!


@requiem @sethro
Hey guys!
Is there a chance you still have those files locally and can share them? They’ve deleted :frowning:
And do I understand correctly that e-1.7 is the only option despite e-1.8.1 exists?

Nevermind :slight_smile:
Managed to install /e/ using additional partitions images from 20221227 (backup just in case) with latest 1.8.1-S /e/ images at the moment of writing:


Glad you found those and good work. I have the files for 1.7 as well so can host those files somewhere if ever needed. Sorry for the delay on getting back to you man!

1 Like

Here is a bottom line to the images issue which will hopefully be included in documentation :slight_smile: