OnePlus 9Pro installation does not complete

Hi all

Today I started to flash /e/ on my new OnePlus 9Pro. As the Install docs mentioned to update to the latest available Android version found and which has to be the same you want to flash from /e/ I updated the phone to OxygenOS which is Android R (11) and the same as the project offers.

I did all the the steps before successfully and the at the point to flash the /e/ image the recovery is Version 0.23 () Active slot: b.

The chapter " Steps to install /e/OS from recovery" reads for point 12:

The PC console will now display Total xfer: 1.00x - which is true (after about 30 seconds)

and the phone reads at this point despite what point 13 says:
The phone screen will now display some text with a message similar to

Script succeeded result was [1.000000]

instead this (I’m writing all messages the shows after step 7)

Now send the packageyou want to apply
to the device with “adb sideload ”…
Supported API: 3
Verifiying update package
Update package verification took 29.4 s (result 0)
Installing update
E:Logical partitions are mapped. Please reboot recovery before installing an OTA update

There is no message like step 13 says: Script succeeded result was [1.000000]

I have waited for about 20 min, and then tried to return the main menu of the recovery.
The phone is reacting on key presses and if I’m trying to return to the main page of the recovery the phone reads:

Installation completed with status 3
Installation aborted.

I’m not sure how to proceed as I don’t want to brick the phone.
Best Alex

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Have look at this thread.

Basically it is suggesting rebooting the recovery ( recovery home screen > Advanced > reboot to recovery)and doing it again. Sounds reasonable?

Hi Chris

thank you for the link and the quick response. I have read it and rebooted into recovery again by shutting down and rebooting into recovery using Volume down and Power button.
Now the phone show the following:

E:Failed to bind mount /mnt/staging/emulated/media/0 to /storage/emulated: No such file or directory
E:emulated failed to bind mount /mnt/staging/emulated/media/0 to /storage/emulated: No such file or directory
E:recvmsg failed (no buffer space available)

What do you think at which stage something went wrong? Formatting/wiping or at installing the image?

Best Alex

I don’t know what exactly you are doing .
Are you in the eOS recovery screen again, slot_b, and the error messages appearing there?
If you are…then try sideloading the OS zip again.

Correct, the messages appears directly after booting into recovery and while the main screen is shown.

OK, wait for finish before returning to home screen

And now it looks like, that the update process is running as expected. The phone shows now Step 1/2 and 2/2.
Thanks for your understanding what the message before is telling the user.
As I did a shutdown to rebooting for the first time into recovery after excuting the steps of chapter Temporarily installing recovery, I did it now the second time and side loading / installing the image is on the way.

There is now only one difference: the shell on the PC show nomore the success message instead of:

adb sideload .\
serving: ‘.\’ (~47%) adb: failed to read command: No error

The phone is now on Step 2/2.

Is it save to redo all the installation from scratch?

Step 2 of 2 means nearly done…

When it looks finished go to arrow at top left of recovery.

Now I restarted the adb server by killing it and starting it again and went again into Apply update - Apply from ADB and now the PC returns Total xfer: 1.00x.

But the phone still does seem to be hanging after Step 2/2.

Again after about 10 min I tried to go back to recovery’s home screen and this time the message
Installation successfully ended (status 0) appeared.

Then I rebooted the phone and now I’m in the setup phase of the phone.

For some reason the messages mentioned in Step 13 Script succeeded result was [1.000000] did not appear.
Thanks a lot for your help

Status 0 is success. Enjoy setting up your new phone!