Oneplus Nord manual installation problems

fastboot version 33.0.3-8952118. Maybe that is not the latest. version. I installed it when I was installing /e/ on other devices some time ago.
Edit: seems to be the latest version.

Without double-checking whether it is the newest, that should be ok. (You could always check for an update though.)

One more side comment

We don’t know much about this yet … always search … I found this …

… if you find yourself in a position to try again … you might run as root / admin if you did not do this last time.

While this

suggests … not an error, but normal !

… if you find yourself in a position to try again … you might run as root / admin if you did not do this last time.
Tried that, but same result :frowning:

When you say same result … does this include Failed to boot into userspace … and then the list of fails ?

You might try

reboot fastboot

in the hope of booting into fastbootd and then the script being able to pick up from the point of failure.

I get the same error:
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.
This is after the script tries to reboot into fastboot. Afterwards all writing commands result in the error “Flashing is not allowed foor Critical Partitions”. After the “waiting for any device” message when trying to reboot into fastboot there now is no long pause, like there was the first time i tried. Maybe 1 or two seconds and then the script carreis on with the menitioned message. No time to type a reboot command at that pooint. Or can you pause the script?

I don’t think you can realistically “pause” the script, you can only hope that the script is written in such a way that it might be able to pick up where it left off.

You might read the comments section at the end of the guide in case the different wording there allows you to understand the limited scope of this method. You have never mentioned a fastbootd screen – notice how the author finds this significant.

I do understand this is very hard when you have no hands on experience of this sort if thing.

There will come a point where you have to say that you have exhausted the fastboot route.

Avoid going beyond what you can understand !

fastbootd is equivalent to booting fastboot into userspace. If you get 2 refusals to boot into userspace it didn’t work.

Edit There is another thing covered in the comments section, that a fastboot method may not be able to downgrade Android version, or Android sub-version. (However remember that you do not want to upgrade Android version ahead of /e/OS version.)

The scope of what I understand is indeed limited, but since I bricked the device already, I have nog choice but to go on and hopefully learn a thing or two ;-).
The MSM guide you gave a link to seems rahter straight forward, but then again so did the guide to reset to stockrom via fastboot. I will search some more, but if I don’t find new “fastbootpossebilities” I’m afraid I will have to jump into de MSM ESL options, although I really don’t know what I’m doing. No-one will die, it’s just a shame of a good phone and in my case € 130,= if that definitely kills the device. Life’s an adventure!

Ok, I took a deep breath and took the deep dive into the MSM method. It was a bit of a proces, lots of reading, but I installed the Qualcom USB drivers, got the device into ESL mode and launched the MSMDownloadTool V5.1.35 – avicii_14_E.04_200716.exe and… Sahara communication failed :-(. But after I disconnected, rebooted to fastboot, turned the device of and reconnected while holding the UP and down Volume keys, the program started runnning and flashing the stock rom without any error messages this time. Then the phone seemed to reboot to Android. The onepluslogo appeared and I had to choose English as language. But then it booted to fastbootd. I could choose te reboot to recovery or to fastboot. rebooting just resulted in the same start screen asking for the language. I powered the phone off completely and then connected to the pc again. To my surprise the battery loading icon apeared saying that there was 1% of juice left. This is really strange since the battery was 100% full before the MSM operation. So I waited a while for the battery to charge and tried to restart… Now it did restart in android Oxygen 10.5.2!!!
What a relief. I’ve never been so happy to arrive back at square one after a week of work :rofl: :rofl: :rofl:
Now I’m going to leave it for the day and try ot install E OS again tomorrow.
aidb and hirntot, thnx very very much for all your help so far. I hope I’ll finally get to enjoy the Oneplus Nord in /E/ but at least I got my phone back now.

Ok, I can’t wait;-). I unlocked the device already. aibd, you asked me before if I was sure that the device had android 11 on it. Is that important and should I upgrade to Nord OxygenOS11.1.10.10 AC01BA before installing /e/? Nothing is mentioned about that in the /e/ installation guide for the Nord.
I’m unsure about the part “Ensuring all firmware partions are consistent” It comes after the installing a custom recovery using fastboot. It seems all my problems started with unhealthy partitioning and I got stuck before this part already, I was wondering if I shouldn’t check the partitioning before tryiing to install a recovery.
Last but not least, is it better to install TWRP as recovery. I’m familiar with TWRP, but not with the custom recovery that the guide is mentioning and last time I failed to install it.

You are right – this is missing from the install instructions. I regard the following as a prerequisite

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I can understand your feelings about “Ensuring all firmware partitions are consistent” but this only seems to have gone wrong as the Custom Recovery step had failed for some reason.

hmmm … or you could take on trust that OxygenOS had left everything nicely set up.

I use TWRP (on different devices) – and TWRP is listed for nord. You could check some recent nord threads on the forum for reassurance, perhaps.


I’ll update tot Andriod 11 first.
I already downloaded the latest twrp vrsion from mauronofrio. I think I will try to install that instead of the /e/ recovery for the nord.
Keep you posted

Succes!!! After the MSM reset and upgrading the stockrom to Android 11 everything went competely smooth. I decided to stick to the guide and use the /e/ recovery after all. I got a small heart attack when after sideloading and installing the zipfile, I did get the Total xfer:1.00x message, but on my device not the "Script succeded result was [1.000000] message, but it rebootet to the /e/ os without any problem.
So happy :grin:
Thnx again everyone who helped and especially aidb and hirntot. Now tomorrow I can get some work done :crazy_face:


I had what looks like the same ordeal today as you did in this post.
Care to outline the steps one would take to manual install /e/ os?
It seems the guides are not uptodate.
I had previously installed on Android 10 but now with 12 it was a 5 hour disaster

Hello together,
yesterday I bricked the second OnePlus Nord AC2003 avicii. One should have been a present for my daughter. Now I have two zombies.
One shows the “destroyed”-screen from the post of june 14. The other shows

I am out of patience and looking for someone, who will try it for me to bring the phones back to life with /e/. I would like to send the phones by mail. Of course I would pay for the work.
Please write me on, my name is Frank.

Hij Frank, I am no expert at all, bit in the end it was nog that hard tot inastall the oneplus firmware andere boring my iPhone back tot life. Andere after that instelling e was a breaze. I’m on a skiing Holiday NOS but next week I’ll be back and I could try tot help you yhen


Frank Scholz via /e/OS community schreef op 25 december 2023 11:48:04 CET:

| wodorfer :de:
December 25 |

  • | - |

Hello together,
yesterday I bricked the second OnePlus Nord AC2003 avicii. One should have been a present for my daughter. Now I have two zombies.
One shows the “destroyed”-screen from the post of june 14. The other shows

I am out of patience and looking for someone, who will try it for me to bring the phones back to life with /e/. I would like to send the phones by mail. Of course I would pay for the work.
Please write me on, my name is Frank.

Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

– Verstuurd vanaf /e/ Mail.

Hi Diederik,

vielen Dank für Dein Angebot. Ich wünsche Dir einen schönen Winterurlaub und freue mich darauf, anschließend von Dir zu hören. Ich habe mich echt verirrt in dem Dschungel von adb, fastboot, den richtigen Abfolgen usw. Ich verstehe auch nicht richtig, was ich eigentlich tue, sondern folge den Anleitungen. Und wenn die nicht stimmen…

Mit diversen Samsung-Geräten, einem OnePlus 7 und meinem Fairphone 3 hat es bisher immer geklappt. Ich bin Deutscher und mein Englisch ist holperig, so lasse ich ChatGPT das hier übersetzen ins Englische und ins Niederländische. Du bist doch Niederländer?

Herzliche Grüße


Hi Diederik,

Thank you very much for your offer. I wish you a wonderful winter vacation and look forward to hearing from you afterwards. I’ve really gotten lost in the jungle of adb, fastboot, the right sequences, and so on. I don’t really understand what I’m doing, I just follow the instructions. And if they’re not correct…

It has always worked with various Samsung devices, a OnePlus 7, and my Fairphone 3 so far. I’m German, and my English is a bit shaky, so I’ll let ChatGPT translate this into English and Dutch. You are Dutch, aren’t you?

Warm regards,


Hallo Diederik,

Dank je wel voor je aanbod. Ik wens je een fijne wintervakantie en kijk ernaar uit om daarna van je te horen. Ik ben echt verdwaald geraakt in de jungle van adb, fastboot, de juiste volgordes, enzovoort. Ik begrijp ook niet echt wat ik doe, ik volg gewoon de instructies. En als die niet kloppen…

Het heeft tot nu toe altijd gewerkt met verschillende Samsung-apparaten, een OnePlus 7 en mijn Fairphone 3. Ik ben Duits, en mijn Engels is een beetje haperend, dus laat ik ChatGPT dit vertalen naar het Engels en het Nederlands. Jij bent toch Nederlands, toch?

Hartelijke groeten,


Hi, I am trying to bring Frank’s phones back to life, but no luck so far. One still had the flimsey recovery of Oneplus working, so I tried to flash TWRP recovery, but that only resulted in losing fastboot mode :-(. Trying to get the phones in EML mode has not worked so far. I seemed to get 1 phone into EML mode. I could see the Qualcomm HS-USB QDLoader9008 (COM4), but there was a yellow triangle warning sign next to it and nothing happened when I tried to flash the Qualcom firmware. Now I don’t get EML at all anymore. I managed to bring back my own phone back to life with the help of this site:
It suggest a way of getting into EDL mode:
Another way of getting into EDL mode is used if your phone no longer boots into Android. You have to completely power down the phone. Press both the volume buttons simultaneously and hold for 5 seconds (NO POWER BUTTON ) and connect to PC. For devices older than the 7 series, only the volume up button for 5 seconds is required.

This doesn’t work on Frank’s phones Any ideas?

Just a thought; for this method “completely power down the phone” (for some phones) may not be so easy.

Have you tried to fully discharge the battery maybe for an extended time (one would ideally want to simulate disconnect the battery).

Edit At the next stage I am not certain if you can now engage EDL from fully discharged – try first … or whether one would then need to recharge the battery without engaging the faulty system.

This thread mentions “correct drivers” and “timing”. EDL may last only a few seconds (less than the 10 seconds quoted in the OnePlus Community link)

This link (showing 5 Nord variants) may be significant if you need to confirm identification of the device.

aibd, thanks foor the help. I finally managed to get 1 phone recognised by the MSM tool by pressing both the volume + and - and power buttons for mayby 20 seconds like Ytube21 suggested in this thread: that you found.
Now I have a working phone with adroid Nord OxygenOS on it. I will upgrade it to the latest android version and then try to install E os on it.

1 Like

Before somethuing goes wrong again, I have a question about the Android version. I have android 11 installed with build no (model is AC2003). I read in the E install guide ( that I have to make shure that I upgrade to the latest version of Andoid 12 before starting the installation of E OS. But when I go to system updates in the device it says that the system is up to date. As I understand, it depends one Oneplus to enroll android 12 to my device and since I just managed to roll back to android 11, I suspect, that waiting for Oneplus can be a long wait.

Now when I follow the link in the installation guide to downloads for Avicii, I find Android Q, R and S. Am I correct in assuming that Android Q stands for Android 10, Android R for 11 and S for 12? And if so, is it safe to download the installation files for Android R for my device with on it and install them?