Oneplus pro 9 not working after flashing e/os

Hi, I am trying to get my OnePlus 9 Pro working again as after the e-10 update its stuck on qualcomm crashdump boot screen.

None of the all posted e-1.8, e-1.9 and 1.10 image + recovery seem to work anymore. these in combination with any of the listed dbto + vendor_boot files. I have tried all possible combinations, most of them boot me up to a non working touchscreen.

Please help

You are trying to run e-1.10-s ? Android 12, Lineage 19.

The current Lineage build linked on the mirror.math.princeton resource are now Lineage 20.

In light of your comment OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #10 by MrX – I cannot find it now but I once linked on this forum an XDA thread explaining how those princeton files are generated. It might be useful to search the subject there.

1 Like

Go to

and extract the proper files from the downloaded e-OS images.

Important note: if a successful install, do not use the e-OS update from the installed OS on the phone (Oneplus 9 Pro) itself. In other words: You will get stuck to the installed OS version. OTA will not work. Touch will become completely non-touch and you have to wait until the battery is completely empty. A total e-OS reinstall is required from this point on.

How do I know? This is the second time that I have to reinstall e-OS from scratch on Oneplus 9 Pro (1.8 → 1.9 and 1.9 → 1.10). It sucks incredibly.

1 Like

I tried to extract the dtbo and vendor_boot from the e-10 image and flashed those before flashing the e-10 image. It gives me the exact same problem.

Though I will try it again and see how it goes.

PS. you do not have to wait until the battery is completly empty, just pressing the volume up and power button for 5+ seconds will turn the phone off.

Thx for the tip! Appreciated.

Do note the guide for flashing “implies” that you need to reboot/restart in between the some steps. My experience: just execute all the steps after each other in one continuous flow.

I’m about to flash my oneplus 9 pro also (with the extracted img files). Keep you posted.

Microsoft Windows [Version 10.0.22621.1555]
(c) Microsoft Corporation. All rights reserved.

C:\Users\rle>fastboot devices
12345678        fastboot

C:\Users\rle>fastboot flash dtbo "G:\Hardware\OnePlus\9Pro_LE2123\Dev\extracted_20230425_195531\dtbo.img"
Sending 'dtbo' (24576 KB)                          OKAY [  0.078s]
Writing 'dtbo'                                     OKAY [  0.078s]
Finished. Total time: 0.156s

C:\Users\rle>fastboot flash vendor_boot "G:\Hardware\OnePlus\9Pro_LE2123\Dev\extracted_20230425_195531\vendor_boot.img"
Sending 'vendor_boot' (196608 KB)                  OKAY [  0.531s]
Writing 'vendor_boot'                              OKAY [  0.625s]
Finished. Total time: 1.172s

C:\Users\rle>fastboot flash boot "G:\Hardware\OnePlus\9Pro_LE2123\Dev\recovery-e-1.10-s-20230413279105-dev-lemonadep.img"
Sending 'boot_b' (196608 KB)                       OKAY [  0.532s]
Writing 'boot_b'                                   OKAY [  0.563s]
Finished. Total time: 1.110s

C:\Users\rle>adb sideload "G:\Hardware\OnePlus\9Pro_LE2123\Dev\"
Total xfer: 1.00x

Do note the boot_b. boot_a also exists. This can cause issues when “restarting/rebooting” between various steps. Use the recovery menu on the phone to reboot into recovery mode or bootloader mode and check the boot partition: boot_b on the phone (in this example) must match what is stated within the terminal window.

1 Like

Thanks for the information. Did this work at he end?
Could it be that my phone is just on the wrong firmware version?

As I did flash the official oneplus firmware back and updated it to the official android 13 version of oneplus pro 9 a week ago.

Installing, e-1.10-s | Android 12; the install instructions advise against this.

It is important that you know that downgrading Smartphones on OS versions greater than the /e/OS OS version you plan to install, can cause instability or at worst brick some devices. We recommend that you check your current OS version, before attempting the installation.

1 Like

Yeah that is stupid of me, I thought e-1.10 was based on android 13.
Will reflash official firmware and update to firmware android 12 and then flash e-1.10 again.
Thanks for the heads up.


My phone works again as expected. But indeed, also as stated by aibd, I only did upgrades, no downgrades. The latter is extremely tricky.

1 Like

So I have flashed the official firmware back on the phone, updated it to android 12.
Then followed the guide, extracted the dtbo and vendor_boot from e-1.10-s-20230413279105-dev-lemonadep.

Flashed dtbo.img and vendor_boot.img, flashed recovery and flashed e-1.10.
Rebooted now stuck on Qualcomm CrashDump Mode.

So for some reason its not working out for me…
Anyone has a clue?

Fixed it: OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #16 by gael

1 Like