Only E-network in Germany

Hi, I have added your ID to the German language part of the forum. Pl check if you are able to post now.

2 Likes

@Manoj

Yes, now it’s possible, thanks a lot.

Maybe related: I’m also unable to roam in Germany using a Motorola G4 Play with a UK sim, see Moto G4 Play (harpia) - voice call inaudible when roaming abroad (#5432) · Issues · e / Backlog · GitLab

I found time to insert a german Vodafone SIM into SIM1 on the G5S and it uses the 4G network straight away. Not a general device issue.

Carrier network type is on “Global” what resolves to “LTE/CDMA/EvDo/GSM/WCDMA”. VoLTE is active. Within *#*#4636#*#* menu it is naming the prefered networktype “GSM/WCDMA/LTE (PRL)”. IMS is registered and VoLTE active, no VoWifi with this SIM (dns is on carrier network dns). The PRL in that list is for Preferred Roaming List btw.

It can’t be the network, as I have no problems with the same SIM card in a 4G-capable feature phone.

Which provider/country issued your SIM? this will give some more keywords to search for.
Could it just be the APN settings that are picked for your SIM that are a problem?

A good sanity check would be to insert another SIM card into your G5S - of a friends if you only have one.

1 Like

Hi, first of all thanks. I need to work my way into it a little bit, I’m not really versed in these things.

That’s what I’ve got.

For me, it says ‘4G-Calls’ under ‘Mobile Network’ and it’ s activated. Should be the same, I think.

That’s what I’ve got.

Nope, mine says:

IMS-Status

IMS-Registration: Not registered
Voice-over-LTE: Not available
Voice-over-WLAN: Not available
Video calls: Not available
UT-Interface: Not available

Is this already the cause of the whole thing and can settings be made so that IMS is registered and VoLTE is available?

I have found a few threads on the Internet in which it is described that SIM cards from my provider o2 do not get along very well with Motorola smartphones and that everything worked again after inserting a Vodafone card.
So do I just have to get a Vodafone SIM card?

If this means that the DNS of my provider o2 is used, then this is the case or rather activated.

I don’t know, I took some screenshots, maybe you can use them to see if there’s something wrong?

IMS (volte or “4g/hd voice”) registration happens after the 4g network band is used, IMS is no precondition to have a 4g data connection - sorry this introduced confusion. Your APN settings look proper for o2 prepaid

So do I just have to get a Vodafone SIM card?

No, I used a postpaid telefonica (o2/drillisch/simplytel) SIM card and 4g worked straight away too - the network carrier settings pertaining to the bands are the same: Global / “LTE/CDMA/EvDo/GSM/WCDMA”.

  • within the “4636” settings right below the SIM card slot (“Phone 0”), do you have a IMEI number for the slot the SIM card is in? (and in both slots too to test the other). If the IMEI is zeroed then it should be the cause of trouble
  • I really think you should do the “sanity check” with another SIM card from any friend and be at a location that the friends SIM card in his/Her phone had LTE available
  • o2 startet ab 1. Februar mit LTE für Prepaidkunden | O₂ Community (6 year old, not sure if answer of o2 support is still valid in general or applies to your card) - says only new simcard activations after 2016 are LTE enabled
  • you can also give the support a call and ask them if the SIM is LTE enabled
1 Like

I can rule that out, in another mobile phone (Nokia 220 4G) I have LTE with this SIM card.

Yes, the IMEI is displayed for both (Phone 0, Phone 1). The SIM card also works the same in both slots.

I had hoped that it was due to a bug in e OS, but if everything works fine for you with the same smartphone, it probably all boils down to a hardware defect.

But I will still do the sanity check, maybe a miracle will happen …

I will report the result then.

Thanks so far

Unfortunately, the miracle did not happen, even with a different SIM card, E reception remains.

The device probably did not tolerate the installation of various alternative operating systems very well … :wink:

did you yet consider or reflash to stock partitions. Test, and if successful, flash /e/ again?

Memory is hazy and it can differ between devices: just flashing the modem partition wouldn’t yet change “lab conditions” for testing as the firmware files get copied over into some vendor lib directory during flashing. Not sure if this is the G5S approach but possible. So 1. back to stock partitions - 2. test - 3. reflash /e/ ?

One could do this by hand: flash modem partition and copy files over though, but you’d need to read into the process so just flashing can be simpler. Motorola offers images for stock flash or in doubt XDA.

1 Like

I’m not 100% sure if this means completely reinstalling the stock ROM or if it’s about specifically deleting certain parts of the current partition, to reinstall e OS directly afterwards!? (Maybe I’m thinking much too complicated again … :thinking:)

If the former is meant, this is probably what it’s about: [ROM][8.1][STOCK][MONTANA] Android 8.1.0 Oreo - Stock Firmware (Fastboot & TWRP) | XDA Forums

I stupidly didn’t note the number of the stock ROM, so I don’t know which version would be the right one …!?

Do I need to find a RETEU (Retail Europe) version or does it not matter?

How trustworthy are files from the above source (Androidfilehost) or does Motorola also run an archive where I can download such ZIP files?

Reflash completely to the latest stock (8.1.0) - the “everything” approach is easier. You’ll lose all your data. Test SIM in Stock too before flashing /e/ again.

[Index] Motorola Stock Firmware | XDA Forums points to lolinet mirrors - firmware, software, iso etc. for the montana. It has “reteu” versions

Trustworthy? legit question, but hard to unearth hash sums for the files from an official source. I didn’t find them at a motorola site anymore, but you can try. I understand your concern.

Pick out a guide from XDA maybe if there is any caveat about flashing stock, I never did this on a Moto G5S (but to others). Usually a lot more partitions are written with stock. Take care not to overwrite the partition holding onto the imei (those can have a second backup partition that copies over its values if the original is empty/zeroed).

1 Like

I installed the stock ROM with this file and according to these instructions, but exactly what you warned about happened. After that I had no network at all, because the IMEI had disappeared, which remains so even after returning to /e/OS. I can’t imagine how this could be prevented, since you are forced to follow the installation steps!? It was also somehow too much hassle for me (or I was just too lazy … :wink:) to backup the efs folder. Is there anything left to save or is the device now finally a case for the garbage can?

It would probably be the best if I buy a Teracube with /e/OS pre-installed … :grin:

I will check my montana for partitions that have a backup of the imei. I think it is “persist → /dev/block/mmcblk0p30”. From the guide you used: “erase modemst1” (and 2) can be legit, imei should get restored from a partition (let’s assume “persist”) on boot. Given this partition wasn’t overwritten in previous flashes and it worked from modemst1+2 since.

As last resort, if you have screenshots of your imei I guess one could restore the digits in a partition too, you can send the imei per DM and I try to prepare a partition image if you find no other way. But would be a first, I think there’s some cryptography involved outside of my league.

Edit: this gives some context for the montana: Fix Persist, resolve IMEI=0, Volte, 4G, Explanation, Requirements | XDA Forums

1 Like

while the lost-imei is one more escalation on xkcd/349, prior to this I wonder if this would’ve helped: Moto G5 (& Moto G3) does not connect to cellular data (#4548) · Issues · LineageOS / issues / android · GitLab - the workaround at Moto G4 Play: no cellular data after upgrade to 17.1 (#2099) · Issues · LineageOS / issues / android · GitLab

1 Like

I had once omitted these two commands during installation for interest. However, the result was that the ‘Mobile network’ section was completely non-functional.

Fortunately, I have the packaging of the smartphone where they are on it. :wink:

Did that, but the luck was not on my side …

If I understand it correctly (my understanding in these things is extremely limited …) it’s about the naming/ownership of the files. They are still there, but cannot be found/read by the system of the device!?

With me is in front of the folders oem_2903 and oem_2904, which must not be!?

When I enter the commands mentioned there, only the following appears: chown: bad user ‘rfs’ and at the end it still says oem… in front of the folders.

I still have to deal with the other links.

whatever you do, make sure you have partition backups (as partition image) before you do modifications, especially of that /persist. Use fastboot. Will take away lots of frustration.

I didn’t evaluate the xda imei=0 post in detail before linking, it just skimmed it - sorry. In closer detail, it targets Nougat. For Oreo (Android 8) ownership was changed to what I see in your screenshots (you downloaded an Oreo image from lolinet).

It’s best to look at the raw user/groupid with “ls -ln”. Not sure how the post can apply to you - you already have the Oreo ownerships (uid:gid) set to 2903:2903 on the rfs directory in the persist, so it should recover?
I don’t know the Code that does repopulate the modemst partitions - so hard to check.

Don’t know what to recommend. You’d need to read the whole 20+ page thread to see feedback. Others (not g5s though) flashed Nougat, booted, flashed Oreo, and got their imei back - some init/update process doing its thing. Seeing the Code that does repopulate the modem partitions can help.

Here’s some info I took from the montana (mountpoints are /e/ though) for comparison