OSMand Wifi Location and Mobile Network Location not working?

Hey Community,

I would like to use OSMand on my FP4.
But it seems to have no Wifi-Location as well as Mozilla Location Service. (Says: A-GPS data downloaded …)
GPS is working perfect.

HERE WeGo and OpenTopo have none of these issues. Precise location is found within seconds after opening the app.

I think I have enabled all the stuff possible on the phone. And I am running the latest version of eOS.

Has anyone an idea what I could do to make it work?

Thanks in advance,


Ok - here some updates:

I have found out now, that I have to activate the “Google Geräte Registrierung” to make the Location Modules work with OSMand …

It works now from time to time, takes very long and is very inaccurate (->Which makes me think that the wifi-location still doesn’t work)

Ok after some testing around I have now found out, that it has nothing to do with the “Google Geräte Registrierung” …

Every time I start OSMand after having it (real) closed I have to switch off and on the Mozilla Backend, then I will have a wifi-location as long the app running (e.g. in background).

Closing the app means I’ll have to do the off/on thing again … :-/

Very strange …

Does anyone use OSMand with a FP4 and eOS?

FP3 works for me and without any special settings needed. The only thing I did manually was downloading maps.