OTA updates installation error

I use a Sony Xperia Z5 Compact and try to find out why I can download the OTA updates but they cannot be installed.
Had the same before and now again on r1.6.
Searching the forum showed me the problem sometimes occurs, but no solutions for it.
Last time I “dirty-flashed” the update via ADB, but I guess thats a risk that something gets broken or lost and I really would like to get to know the reason as I have other devices like this in my family.

Please help! :slight_smile:

I have one of these devices. I’ll try this out and report back

  1. Do you have TWRP installed as your custom recovery. eRecovery does not work. The correct recovery is TWRP, specifically the version at https://drive.google.com/file/d/1CTubNXg5ijhMxmcdrR6Ul45oGu8vFrDr
  2. What version of /e/OS is currently installed? (Check Settings | About phone | Android version). Do you have Android 10 / Q or 11 /R build installed currently/

Hi Pete, once again! :slight_smile:
It runs 11r, v1.5
I use TWRP
Will try your version!

Hi Max

I’m currently checking the 10/q version. Trying to upgrade from 1.4-q to 1.5-q.

If that works, I’ll try 1.4-r to 1.5-r, then 1.5-r to 1.6-r (if it’s offered in Updater app)

I installed your recovery and currently download the update fresh.
The OTA updates when I did youn q have benn working fine btw!

So for you it’s just an issue with the R builds?

I am quite sure theres no problem with the builds, its a problem with my device.
Your recovery didnt solve it either.
I messed up something when I tried to do a backup with TWRP some months ago and then had to completly wipe everything.
Now some “internal route” or so is missing I guess, but I have no clue how to find out whats the problem. Not even talking about the solution…
Any ideas?

I think you’re correct. I’ve done the following and not encountered any problems:

  1. Clean flashed e-1.4-q
  2. Updated to e-1.5-q using Settings | Updates
  3. Dirty flashed e-1.4-r over e-1.5-q (slightly surprised that worked, but it did :slight_smile: )
  4. Updated to e-1.5-r using Settings | Updates
    5 Updated to e-1.6-r using Settings | Updates

I guess my next step would be to dirty flash the second most recent build (1.5?) over your current setup. (Sticking with the same Android version, after making backups with both TWRP Android Backup and Restore Tools project Android Backup and Restore Tools project

Then try the OTA update. If it fails, try and get some logs. If the failure occurs:

  1. before the the device reboots into recovery: use Android debug log (logcat): http://bit.do/logcat .
  2. after the device has rebooted to recovery: use Recovery (TWRP/SHRP) log: follow FAQ #2 A at https://forum.xda-developers.com/g4/development/recovery-twrp-3-touch-recovery-t3442424/post68249027#post68249027.

Logs will give us much more chance of working otu what is actually causing the problem

If the update works OK, then remember those steps for next time it fails :slight_smile:

The “nuclear option” would be to reinstall stock Sony Firmware and TWRP, then reinstall the latest /e/OS, and either restore your most recent backup or do a fresh install of all your apps and data :frowning:

But I wouldn’t bother doing that if dirty flash works for you: I’d just live with the fact that OTA update doesn’t (or doesn’t always) work.

(By the way did you seem my forum post about the future of Z5 C as an /e/ device (or the associated gitlab issue. Id be interested i your response)

Thanks Pete, thats quite surely to much hassle for me!
The crazy thing is I am coming from what you call “the nuclear option”!
It was my way out of the misery with TWRP…
But still it doesnt work!

Anyway, as I am a big fan of the Z5C and you even offer a LOS + microG I will probably go that route as well :slight_smile:
Big thanks again Pete!