Outbound MMS Fixed on Mint Mobile (T-Mobile USA MVNO)

TLDR: Through lots of trial and error, I managed to get outbound MMS working - here’s my story.

I recently purchased a Murena Fairphone 4 and had a really good experience out of the box except for one thing - sending MMS photo messages was hopelessly broken. Literally, everything else worked great:

:white_check_mark: 5G data
:white_check_mark: Calls in & out
:white_check_mark: SMS in & out
:white_check_mark: MMS inbound
:x: MMS outbound

After quite a bit of back and forth with my carrier (Mint Mobile) confirming APN settings and them resetting the SIM card on their network, they eventually gave up, blamed it all on Murena and /e/OS, and said they wouldn’t support me any further. I started troubleshooting things myself, found this forum with lots of other MMS complaints but no solutions that worked for me, contacted Murena support (who I am sad to say have yet to even reply to my initial inquiry), and even hit up the nice people over in the Telegram support group. After many iterations of DNS setting changes, manual MMS proxy settings that my carrier disapproved of, turning various things on & off, rebooting, etc. I had gotten exactly nowhere. I eventually started trying changing various things out in my APN settings, and that’s where I eventually solved the problem by simply adding xcap to the ‘APN type’ setting. For anyone else on Mint Mobile, here’s the exact settings that made everything work for me as of the time of this post.

Name: Mint
APN: Wholesale
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://wholesale.mmsmvno.com/mms/wapenc
MMS proxy: Not set
MMS port: 8080
MCC: 310
MNC: 240
Authentication type: Not set
APN type: default,supl,mms,ia,xcap
APN protocol: IPv4/IPv6
APN roaming protocol: IPv4/IPv6
Bearer: Unspecified
MVNO type: GID
MVNO value: 756D

I don’t know for certain, but I suspect that this might also work on T-Mobile, as Mint Mobile is an MVNO that exclusively operates on the T-Mobile network here in the US. Best of luck to everyone else out there having MMS issues!


indeed, the xcap attribute to the T-Mobile MMS APNS entry was added to S (in /e/) + lineage-19.1 - https://review.lineageos.org/c/LineageOS/android_vendor_lineage/+/332689 - as you say, any tmobile MVNO would want to look into adding it

xcap is interesting, telco acronyms never stop to amaze me. It’s a xml driven configuration/capabilities service

MMS on Mint was always a weak point for me on /e/, part of the reason why I’m running Lineage and keeping one eye here for the time being. I’d be interested in seeing if this fix holds long term.

Say, I know your MMS issue is fixed now but was wondering, did you ever have a separate Mint MMS APN? Seems that’s becoming the norm these past few years.

Yesterday I got rid of my last T-Mobile number. Wanting to have at least one non-VoIP device I ported the number to a new Mint Mobile SIM. Much to my surprise the porting was immediate. While in the middle of the activation and account setup the number was ported in and TMO SIM deactivated. Had to go WiFi to finish up.

Anyway, once the Mint SIM was installed I got a flood of messages. One of them had APN settings. One for data and one for MMS. Once setup I tested MMS before and after re-enabling my network tools (DNSCrypt, Tor). Sending and receiving is A-OK so far…
Both APNs are simple, too. ‘APN type’ of just default and mms, respectively.
Been a couple/few years since I’ve had Mint on Android (do have a line on a PinePhone) and don’t remember a separate MMS at the time. I do like that IPv4 is default since that is what I only use. IPv6 can be problematic and not very compatible with a lot of networking tools. Better noeadays than in recent past.

Note that this was on a OnePlus 8T with crDroid Android 11.
Just some random randomness. :upside_down_face:

This topic was automatically closed after 90 days. New replies are no longer allowed.