Partial Fix! Trying to reinstall miui after installing /e/ and files get corrupted ONLY while in TWRP

What the title says. I am trying to reinstall MIUI so i can give the phone to an older person since /e/ was supposed to be for me originally and he wants me to change it back. After reinstalling TWRP when i try to open the storage this is what it shows… and it stays until i reboot my phone. Then after going to TWRP again it happens again. Also tried a factory reset and happens again. Also i can’t put files in my storage while like this. Also tried to put Disable Forced Encryption and Miui Rom on internal storage folder but it reads them as just files.

Edit: I FIXED IT. One other guy had a similar problem and this is was his solution (no sd card needed)

I downloaded the Android 12 (sys_ext) one from there and IT WORKED. Another edit: It was partially fixed, now its stuck on MIUI logo on reboot and every time i turn it on. Will update if i find the solution.

Your Internal Storage is encrypted and seemingly TWRP for your device can’t handle this, see Why doesn't TWRP support encryption on my device?

Are you using the latest TWRP version for your device? See

1 Like

Yes, i’m using the latest one. I downloaded the most recent one (3.7.0) that only. It’s weird that it gets encrypted now of all things, i mean i installed e with same method while having one factory reset for app lounge. Also i downloaded latest version only and not sha256, md5 and PGP-signature one(asc file).