Permission: Prevent Phone from sleeping

I am using the latest version on my Mi11 Lite 5g.
Unfortunately, the phone app seems to go into standby with it. As soon as the screen goes into standby, the microphone and the loudspeaker of the mobile phone sound off. When I unlock the phone again, the call is still there, but during standby there is silence on the line. I can’t find the setting “Prevent Phone from going sleep” in the phone app. I now think it is a programming error or bug.
Or does anyone know the solution?

Iḿ using the latest Version:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Sounds like it would be worth eliminating “Screen timeout”, to see in what way the buggy behaviour continues; found in

Settings > Display > Advanced > Screen timeout

30 minutes is the max setting.

Maybe someone else can point to a “sleep function” – I expect Screen timeout to be cancelled by an incoming call.

Just a thought … perhaps worth checking Settings > Sound > Advanced for Do not Disturb; another Sound setting is a shortcut to “Prevent ringing”.

Just got a used Mi11 and see the same behavior on the current 1.17-s build.
Have you ever figured out a solution to the problem?