Phone app keeps crashing system UI

I’m trying to install /e/ OS on my new Fairphone 3. All works well except for the phone/dialer app. Each time I try to call someone or get called and answer, first the phone app crashes (states: “[phone] app doesn’t react, do you want to close it?”) and then the system UI crashes (same message then device gets rebooted). Does anyone have an idea how to fix this?

I’m not the most techy guy but I already tried a few things to solve this:

  1. Multiple reboots, didn’t have any effect

  2. Installed multiple builds (listed below), also no effect.
    [IMG-e-0.10-p-2020080666687-dev-FP3.zip]
    [IMG-e-0.9-p-2020072865179-dev-FP3.zip]
    [IMG-e-0.9-p-2020061158052-dev-FP3.zip]

  3. Tried using the phone app without a sim-card inserted. App states that there is no network available and then crashes phone app and system UI.

Help would be very much appreciated!

[btw, I installed the OS following the instructions on https://doc.e.foundation/devices/FP3/install]

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Anyone able to help?

Hi Dizzle,

I don’t have a Fairphone, so I can’t give you any specific advice,
but I’d say that, since you’ve already tried three of the five builds that are online, try the remaining two, and maybe also try to format the partitions, and change the filesystem from ext4 to ext3 and then back to ext4 (it often works…).

I don’t know what else to suggest unfortunately, I’m sorry :crossed_fingers:

Hi Claudio,

Thx for the advice! I will work on this, and let you know if it works.

Best

It happens to me from time to time, but on random apps. I’ve had e-0.10 and e-0.11