Phone boots into TWRP after upgrade to e-0.11


I upgraded my Xiaomi Pocophone F1 “beryllium” to via OTA. After the upgrade the phone started correct. But after the upgrade I don’t have root. Due to my encryption Magisk is not installed. As with every update I wanted to flash Magisk in TWRP. I booted to recovery but I can’t use the keyboard to decrypt my phone.

Did someone had a similar issue? How can I use the keyboard in TWRP. Last time with e-0.10 it worked correct. Now I can’t boot to the system. The phone always boot into recovery.

try reinstalling TWRP with fastboot

I tried reinstalling TWRP with fastboot. It doesn’t work. I saw a strange behaviour. The screen shows fastboot. The phone was connected with the computer. When I sent fastboot flash recovery twrp-3.3.0-0-beryllium.img the screen turns off and I had to start the phone to boot into fastboot. Then I got the message target reported max download size of 536870912 bytes sending 'recovery' (31068 KB)... OKAY [ 0.870s] writing 'recovery'... OKAY [ 0.139s] finished. total time: 1.010s
Seemed to work fine.

After that I tried fastboot boot twrp-3.3.0-0-beryllium.img. The same behaviour as before. The screen turns off and I had to start the phone to boot into fastboot. Then I got the message downloading 'boot.img'... OKAY [ 0.808s] booting... OKAY [ 0.088s] finished. total time: 0.896s

I turned off the phone. It automatically restarts and booted to TWRP. But I can’t enter my password. It seems it doesn’t recognize touch input.

OK, or better not OK :frowning: It seems your kernel is destroyed. You can try downloading MIUI rom for fastboot flashing. Extract it and you will find a Remove all lines except of boot.img line and run it. If you will have luck, TWRP will start normally
or you can try flashing a kernel from here

@harvey186: Thank you. I will try this. It is strange. I upgraded /e/ from 0.10 to 0.11. After the upgrade the system worked normally. Then I wanted to boot into recovery and the error occurs.

I have access via adb devices -> recovery. Is it possible to restore a nandroid backup with the computer?

Sorry, don’t know, never tried. But you can search the web. Could be that you will find a way.
But if you have a backup, you could flash miui rom via, install twrp once more and restore your backup.
But first, save backup outside your device :wink:

I solved my issue. First I bought an USB-C to USB-A adapter. Then I could use TWRP with a mouse and started a NANDroid backup. After that I flashed /e/ 0.11 with TWRP and thats it. Sounds simple but it took me a week to read so much forum posts with a lot of solutions.

Thank you very much harvey186 for your help.

@harvey186: I think I can reproduce the behaviour. When I start my Pocophone F1 to boot into TWRP I have to wait for about 20s until touch will be recognized and I can enter my passphrase.

To reproduce the failure: If I boot into TWRP and unfortunately press POWER + VOL UP twice the screen will be turned off. Then I have to unlock the screen in TWRP and touch input will not be recognized. My TWRP Version is

First aid is to use an USB-C to USB-A adaptor and connect a mouse. With the mouse you can use TWRP and you can reboot.

1 Like