Phone discharging while charging

Hello everyone

Anyone had this issue once and knows an other solution than a new device? It is an xz2c with some years in use, it happen abruptly and it charges over night only to 30 percent. Changec cable and tryied diffrent outlets. I do not think it is an app but will check it as soon it is charged again…

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Click on the loupe on top, type “charging” and press Enter. Look what happens.


Happened to me, once.
Solved by powering off the device, power it back on, then plug in the charger.

It did not help, thank you for the imput.

According to Ampere (charge analysis app) the device supports max is 75 mA. Others have 1500 mA. It peaks after a restart to 750 mA but then quickly goes down. Guess it is over with a great phone…

Maybe you can have the battery replaced?

That would be great, though this would result in a ractory reset (I guess) I would rather migrate to an other device for the meen time. I am not at home for the next 2 months, so maybe later ill fix it. It is a great size for a phone

Since charging problems with similar symptoms came up suddenly also on other devices I would still think it’s a weird software problem, probably depending on rare conditions.

As far as I know, there’s no reason why fitting a new battery should result in a factory reset.

You might be right, I have read that sometimes the port has an issue. Replacing it fixed the issue. I will update to v1.4 who knows it might help. I fear it has an hardware issue, for example from droping. Since i use a magnetic charging cable the port should not have been ‘overused’ from plgin-/out.

Thanks for the response, I will check my options.

A quick recap and kind off solution to the problem I had. I am in Japan since 2 Months, the issue I had started occuring a month ago. So I thought I must have been an aged battery. I was able to get the battery changed without data loss but the problem persisted. Like I habe written before I tried diffrent power outlets, new charger (QC 3) and new A to Type C cable. This week I tried the Type C port on the new charger I bought. I was reluctant to try that since the wattage was higher than the specsheet of the phone. With Type C to Type C it showed that it was charging quickly.

Anybody have a logical explanation for it?

Perhaps I can come in with a speculative explanation.

A Type A port expects an asymmetrical connection to the device.

A Type C port (with its multi-wire technology) is designed to connect “either way up”.

Running C off A might confuse the flow.

Thanks for the expanation. It still bothers me that it happend just on one random day. I wonder how it will work in europe when I am back…

I could have researched better before I answered. :blush: … now that I read


In hindsight it is something I thought about. But made no logical sense to me because the phone charged allright in the most rural area. Getting to a city and charging beeing a problem made no sense. A japanese friend explained to me that the area I was uses 60 hertz as you commented. So I guess thats the solution :blush:

Being back now in Switzerland I tried again and only PD charging over Type C works. No idea why but something must have physicly changed…

1 Like