Phone does not sync to self hosted ecloud

Hi folks,

I am using a Galaxy S10+ with the latest /e/OS as of February 5th 2023 and I have setup the following self hosted ecloud:
A Hetzner VPS CX11 with 1 core and 2 GB RAM and in addition a 2GB swapfile. I know 2 cores and 4 GB are recommended, but I have an old price for the CX11 and would like to keep it and ecloud itself is running fast and reliable enough with that specs and settings. The CX11 has only 20GB storage, so I bought also a Hetzner StorageBox BX11 with 1TB space, mounted it to /mnt/storagebox, moved all data from the default location /mnt/repo-base/volumes/nextcloud/data to /mnt/storagebox/data, umnounted /mnt/storagebox and now I am mounting the storagebox/data folder to the default location, i.e. /mnt/repo-base/volumes/nextcloud/data. Everything works fine, I have full access to the storage, except that it doesn’t sync with the phone. There is no “Device” folder or any other folder created and also photos are not synced.

Is there a relation between the mounted storage and the phone not syncing or is it that totally unrelated?

Any ideas what I can do?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


2GB RAM may not be enough… You could try temporarily stopping the RAM-eater mailserver (you can check with docker stats): docker-compose stop mailserver. Use docker-compose up -d to restart.

Hetzner Volumes are known to work flawlessly, because they are DASD.
What kind of mount do you use to your BX11?

At first, you may enable/install NextCloud Log reader, this will enable access to logs from NextCloud Settings (admin account). Enable Debug & Info+Warnings+Errors.
As an alternative, you may use docker-compose exec -T --user www-data nextcloud php occ log:watch -vvv, then attempt a sync operation.

You may also watch container logs with docker-compose logs nextcloud|less.

Also, you didn’t mention what kind of client you use on your phone.
For debugging, I’d advise to install the official NextCloud client, then watch logs.

Also, what gives a desktop synchronization client? (Appendix C: Troubleshooting — Nextcloud Client Manual 3.7.3 documentation).

Thanks a lot for your advice. I stopped both, mailserver and postfixadmin, but this didn’t help.
I mount the BX11 with the CIFS protocol as suggested by Hetzner on, so I have added the following line into /etc/fstab:

// /mnt/repo-base/volumes/nextcloud/data cifs iocharset=utf8,rw,credentials=/etc/backup-credentials.txt,uid=33,gid=33,file_mode=0660,dir_mode=0770 0 0

whereas both, uid and gid are set to 33. Mounting works just fine, so I am not sure whether this is the issue.

I have the logs enabled and the reader installed, but I am not sure what error message I shall be looking for. Could you give a hint as to that?

I don’t use a specific client on my phone, just the one built in to /e/OS (version 1.8.1-20230205257804-beyond2lte). When I install Nextcloud client on the phone it does sync photos for example. I didn’t try a desktop client, because I am using Ubuntu and I connect to the Nextcloud/eCloud via Online Accounts.

Any message related to files access (permissions, locking, etc).

So, it’s working with official Android client? In this case you may try to remove/add the “” account from the phone.

No, I don’t get any file access related error messages. I also did remove the account several times, but it didn’t sort out the issue either. I also tried connecting the account with http only (not https) because that helped in the past, but also no sync.

Moreover, notes are synced, calendar is synced and contacts are synced as well, I assume as those are davx5-driven. But still no “Devices” folder is created neither do documents or photos sync.

You may try to revoke all sessions for your device, from NextCloud web interface signed with your account (Settings/Security).

Also, NextCloud may experience some trouble with your CIFS volume, and constantly report “Storage Full”.
Is it OK with the Files NC app in web interface?

Thanks Sylvain, I revoked all sessions but no change. Also, the Nextcloud Web App has no problem with detecting the storage and the free space on it.

As a last resort (and this is my last idea) you may attempt an /e/ Drive app reset.


  • be prepared to a huge data consumption
  • ensure you have a valid backup of ALL files (phone & StorageBox)

This is quite simple (all steps are to be done on phone):

  • go to Settings, Apps, locate “/e/ Drive” (use “Show system” in 3-dot menu)
  • stop, clear cache & data
  • reboot phone

/e/ Drive will rebuild its database and, within 1/2 hour, attempt to resynchonize.
Please be patient, sometimes it takes several attempts (1/2h delay for each) to get full sync.

I finally got it working. I am not sure whether this is a coincidence, but I changed the settings in ecloud.cnf from

innodb_buffer_pool_instances = 1
innodb_buffer_pool_chunk_size = 128M
innodb_flush_log_at_trx_commit = 2
innodb_log_buffer_size = 32M
innodb_max_dirty_pages_pct = 90

innodb_buffer_pool_instances = 1
innodb_buffer_pool_chunk_size = 256M
innodb_flush_log_at_trx_commit = 2
innodb_log_buffer_size = 64M
innodb_max_dirty_pages_pct = 90

and now it is syncing.

Thanks again for your assistance!

1 Like

Just another quick question. When I use Nextcloud app on the phone to sync photos I can choose if the photos should be uploaded in folders (one folder per month). Is this also possible with built-in sync?

No, AFAIK /e/ Drive only relies on filesystem folders.