Phone fails to start after OTA upgrade on S9: Custom binary blocked by OEM lock


When trying to boot, I have this smallprinted red line appearing on top of my screen stating:
Custom binary blocked by OEM lock
and that’s it.

After hard-booting I can download a custom OS. However, the download seems to get stuck as well.

Any suggestion is welcome! :pray:

(Not 100% sure if this is due to the OTA upgrade to v 0.21. But since the upgrade my phone is acting weird, and this is the first time I am trying to restart my phone, and apart from updating some apps I didn’t change any settings or so.)

Recovery mode via
Volume Up + Bixby + Power
does not work.

Hello Bram,
I have never seen this problem before. Strange. What recovery do you have installed?
It looks to me that you have to install 0.21 again from recovery. I have 0.22 Q installed on my S9 (G960F) and this is working excellent.
Make a backup if possible from recovery.

Dear Bartmans,

Thank you for your reply.
Unfortunately, Recovery mode does not work.
The only thing that happens the display of this text:
Custom binary blocked by OEM lock

Glad to hear that Q works on the S9 though. Hopefully I will one day reach that stage.


The issue has been resolved. My phone is back and running again, on /e/ OS v0.22 this time.
My data were lost, but (apart from my Minesweeper highscores), I had most of my data safely synced the ecloud.

If anyone else bumps into this issue, here is my solution (with some help from the /e/ helpdesk):
1. reinstall stock ROM via Download Mode to get android running (Revert Samsung Device to stock ROM on Windows PC)
NB: ODIN flash had a crash at odm.img. this was solved by restarting the process and using the CSC ROM file instead of the HOME_CSC ROM file that was mentioned in the guide).

2. install TWRP ([HOWTO] Install /e/ on a Samsung smartphone with Windows easily, points 5 & 6)
NB: In my case, TWRP was deleted every time after rebooting, even though I tried both solutions in step 6. Initially I wanted to use easy installer after installing TWRP, but TWRP stopped existing while going through the easy installer steps. So I continued with step 8 of this howto, made some modifications, but each time got an error that /data could not be mounted. I played around a little bit. with some wiping (honestly i don’t remember what i did exactly) and at some point TWRP was no longer deleted after reinstalling.

3. use the easy Installer to install /e/ (although I think the how to in step 2 would have been excellent, too)
NB: the easy installer assumes that TWRP is already installed. So make sure to do step 2 first.

4. update /e/OS to current version.

Still no clue what caused this issue but I am happy to be back!