Phone is restarting itself and booting into TWRP suddenly

Yesterday I woke up and my phone was at a locked TWRP screen with “swipe to allow modifications” or keep read only.
Because I did not know how I got there I chose keep read only, then reboot, then system.
Everything worked fine again.
This morning I was working on my computer when my phone suddenly lit up and displayed an “e” with a bouncing dot under it. This remained lit up like this for about 5 to 10 min then booted into TWRP again. This time it said “swipe to unlock” I did and rebooted.
I am not sure of the exact time this happened yesterday but this morning was about 9:30 to 9:45.

  • I was a 65% battery after selecting reboot from TWRP.
  • I have had e os installed for a couple weeks now and yesterday is the first time this has happened.
  • for the last 5 days I have not installed anything new.
  • the last thing I installed was battery alarm to set charging reminders.
  • I did enable battery saver at some point a couple days ago but nothing else…

Any Idea what could cause this?
This is on a Samsung A5 (2017)

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

I did it again this morning at the same time.
If I select power off then restart or select reboot the phone boots normally and does not enter TWRP.
It is like there is a setting that causes it to reboot every morning now.

I have seen a couple people talking about going through the recovery process several times in a row to fix a similar issue but their phones just went into TWRP every time they restarted them.

This seems different as my phone worked fine for weeks and only does it by itself; not when I initiate a restart.

is there a setting somewhere in the phone that might do this?

As you had no reply … my first thought was might this be a hangover from the last installed OS or firmware ? Firstly were you sure to Format data at install ? This last point especially if you did not come from Stock ROM.

I do not think any Setting would cause a random restart, but certainly progressively uninstalling recent apps is a good idea. (Maybe also run CacheCleaner, but this is more often useful following an /e/OS update.)

On a Samsung a Soft reset can work around some difficulties, no data is lost except any unsaved work, Vol Down + Power .

You don’t say if you installed Android (10) Q or Android 11 (R). Regarding TWRP, when the /e/OS builds were introduced, TWRP v 3.5 was then current for Android 10, v 3.6 for Android 11.

Might be worth checking Settings > Storage, A custom ROM might require more “headroom”, probably overcautious but I regard 85%, or so, as a sensible top limit.

If you think you might need to go back to fundamentals the install page, includes a link to a Stock ROM, on Windows this would be installed with Odin.

Sorry for the late response. I have been busy gutting my truck and tracking down 3 leaks amongst other things and this kind of took a back seat for a while.

The android version is only 10 (Q) because 11 (R) is still beta.
I believe I have done several soft resets but I did another one just in case just now.
12 out of 32 GB have been used.

Using ADB I have grabbed logcats and kernel logs but I have to leave the phone connected to USB for it to work in android 10 and my phone will not reboot into TWRP if it is connected…

It also turns out that the default is to wipe the logs on reboot so even grabbing the kernel logs from TWRP does give me what I need.

I understand that in android 11 there is an option to run adb via wireless connection but I dont know if my battery would hold out for that…

I found a post that talks about installing busybox which then allows ADB to continue running after disconnecting the USB but apparently the phone has to be rooted first.

I think it would be really cool if there was an option you could just turn on to save logs to the SD card under developer options.

Is there a way I could run the ADB command in a shell or terminal emulator from my phone itself?

I think most builds contain Bug Report within Developer options, this might work for you.

While R builds are marked beta, (may be due to lack of a test device at time of launch, idk) Q builds are end of life and no longer receive updates, so an Upgrade to R is probably a thing to have in mind in the fairly near future.

… and reminded by another poster, there is also LogFox
[HOWTO] log app errors with LogFox on-device to create bugreports.

I will most likely give it a go.

I have good news though. I went through dev options very carefully the other night and found a setting for persistent logs.

I just caught my first core dump and I will see if it catches more over the next few days.
What might you make of this:

<4>[   10.962530]  [0:       recovery: 2372] ------------[ cut here ]------------
<4>[   10.962548]  [0:       recovery: 2372] WARNING: CPU: 0 PID: 2372 at kernel/irq/manage.c:536 irq_set_irq_wake+0x90/0xf4()
<4>[   10.962556]  [0:       recovery: 2372] Unbalanced IRQ 4 wake disable
<4>[   10.962564]  [0:       recovery: 2372] Modules linked in:
<4>[   10.962576]  [0:       recovery: 2372] CPU: 0 PID: 2372 Comm: recovery Tainted: G        W      3.18.91-g05cf350e #1
<4>[   10.962585]  [0:       recovery: 2372] Hardware name: Samsung A5Y17 LTE EUR HWID08 board based on Exynos 7880 (DT)
<0>[   10.962593]  [0:       recovery: 2372] Call trace:
<4>[   10.962606]  [0:       recovery: 2372] [<ffffffc0000095e4>] dump_backtrace+0x0/0x108
<4>[   10.962617]  [0:       recovery: 2372] [<ffffffc000009700>] show_stack+0x14/0x1c
<4>[   10.962629]  [0:       recovery: 2372] [<ffffffc0002e1194>] _dump_stack+0x84/0xa8
<4>[   10.962641]  [0:       recovery: 2372] [<ffffffc0008e3ad0>] dump_stack+0x10/0x18
<4>[   10.962653]  [0:       recovery: 2372] [<ffffffc00001c514>] warn_slowpath_common+0x88/0xac
<4>[   10.962662]  [0:       recovery: 2372] [<ffffffc00001c588>] warn_slowpath_fmt+0x50/0x58
<4>[   10.962672]  [0:       recovery: 2372] [<ffffffc00005b5e0>] irq_set_irq_wake+0x90/0xf4
<4>[   10.962683]  [0:       recovery: 2372] [<ffffffc0004de338>] abov_tk_input_open+0x32c/0x348
<4>[   10.962695]  [0:       recovery: 2372] [<ffffffc0004cb320>] input_open_device+0x7c/0xd4
<4>[   10.962706]  [0:       recovery: 2372] [<ffffffc0004d6530>] evdev_open+0x154/0x1e8
<4>[   10.962718]  [0:       recovery: 2372] [<ffffffc0001135c4>] chrdev_open+0x138/0x168
<4>[   10.962729]  [0:       recovery: 2372] [<ffffffc00010d370>] do_dentry_open+0x260/0x2d8
<4>[   10.962739]  [0:       recovery: 2372] [<ffffffc00010e418>] vfs_open+0x60/0x6c
<4>[   10.962751]  [0:       recovery: 2372] [<ffffffc00011c76c>] do_last+0x8d0/0xb18
<4>[   10.962760]  [0:       recovery: 2372] [<ffffffc00011cbd4>] path_openat+0x220/0x59c
<4>[   10.962771]  [0:       recovery: 2372] [<ffffffc00011d80c>] do_filp_open+0x30/0x80
<4>[   10.962781]  [0:       recovery: 2372] [<ffffffc00010e76c>] do_sys_open+0x164/0x254
<4>[   10.962790]  [0:       recovery: 2372] [<ffffffc00010e894>] SyS_openat+0x10/0x18
<4>[   10.962799]  [0:       recovery: 2372] ---[ end trace 31a4c9940b845130 ]---

I am unsure what is happening here but something must be very wrong because since I have enabled logging my phone will not properly lock. I can lock the phone by pressing the power button and if I try waking the phone using the power button it works… but if I press the home button it just bypasses the lock screen altogether.

I am going to re-flash the phone, use the latest e os for my phone and assume this is the correct solution, thanks to anyone who tried to help.

This topic was automatically closed after 60 days. New replies are no longer allowed.