Pixel 3 - always starts into stock OS - No /e/OS possible?!?!

Dears,

i am trying to get /e/OS to run on my Pixel 3. It was easy on the 4 and 5 but somehow not on the Pixel 3.
I followed the instructions but always end up with the same issue after sideloading v.1.8.
When rebooting the phone it ALWAYS starts back up into Stock Android 12!

Do i need to lock the bootloader (i did not do it with the pixel 4 and 5 btw)? If yes, how do i do it?
I tried it via the recovery file and it ended up in teh phone telling me there is no operating system on the phone anymore!

I am really lost here and looking for support.

When using TWPR btw i see a hint that the slot used is “B” (Flashing A/B zip to inactove slot B) Not sure if this is creating the issue. How do i activate slot A? If this does even make any sense:)

@Manoj i also checked the “known issues” with the Pixel 3 and i did not see this one so far.

Thanks already for the support to all of you.

Best regards,

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

It is an exepected indication in TWRP

.

But you said " i follow the instructions " so i presume you use the recovery-e

As i remember flashing both slot using fastboot is recommanded

If not mentionned in the instructions, you cannot relock the boitloader

Hi @piero indeed i followed the instructions but also tried it via twrp.

I saw some post online where the fastboot flash boot command end with a “…_ab” befor pasting the recovery image.

Anyhow it is hard to find a good instruction for e os to properly flash a and b with a recovery to be able to install e os or alike :frowning: most comments are found for twrp.

Thus i am still thankful for some instructions.

Best regards,

Not seeing any other issues regarding the booting of the Pixel 3 blueline. We have blueline as one of the devices on the shortlist for upgrade to T or Android 13. That may be able to resolve this issue. The tentative ETA for the upgrades is end of Jan early Feb.

Hi @Manoj ,

I was also surprised to encounter this a/b partition issue with the pixel 3 as i never saw a post here about a/b partition challenges. However,it is real with the pixel 3. I thought the community might have gained experience with this issue.

But i understand there is no “e os” way yet and you recommend to wait for a stable android t version? Did i get you right?

Thanks and best regards,

Blueline will get a dev /e/OS T build in Feb 2024 as part of v1.19 release :crossed_fingers:

@Manoj do the Pixel 3 XL will also make it to /e/OS T in february?
I’ve checked the lists of phones to be upgraded to T and there are no mentions for either the Pixel 3 or Pixel 3XL.
Thank you!

yes, fingers crossed. Is there a reason why no stable version is in sight?

Also, the A/b Partion thing should be no issue with version T?

Best regards,

Dears,

i foudn the solution and hence would like to recommend a change in the instructions.

follow the normal instructions found for teh pixel 3 (blueline).

Once you rebooted for the first time into the e os recovery, format the data and go via “advanced” into fastboot mode". You will be doing this on partion b by default.
When you are in “/e/os fastboot”, you the type command “fastboot flash boot_a (/e/OS recovery.img)” in your terminal programm (windows). This will write the recovery onto partition a.
Next sideload the downloaded /e/OS ROM and reboot your device.

Done
This is how it worked for me.

Best regards,

1 Like

Only devices we sell or used to sell on the Murena Store get stable builds.All the other get dev builds.

thanks. Got it.

Have a great day