Pixel 5a stuck in fastboot after flashing /e/ os recovery

I tried to install /e/ OS on my new pixel 5a. I was able to flash the recovery image, but now, whenever I try to go into recovery mode, it gives me “error boot prepare” and just goes back into fastboot. this also happens when i try to shutdown, restart, and start.

I’m not able to install the stock ROM for android now, and I’m starting to worry my phone is bricked.

I’m kinda freaking out right now, as my phone cannot shutdown and has been on for a few hours. Any help would be appreciated

It won’t be bricked, so no need to paniic yet. If you follow installation instructions and learn a bit about the phone itself you should be ok.

In fastboot mode there is an option to power off, yes?

If you can get into fastboot you can also flash stock from there.

Were you on Android 12 when you started this?

So I am able to turn it off now, I just needed to un-plug the phone from the computor.
I believe I was on android 12, not entirely sure as i just got this phone.
Im still stuck in the fastboot menu though. I try selecting recovery mode and resue mode but it keeps bringing me back to the fastboot.

It’s important to know which android version a device is on before starting.

Anyway, is fastboot communicating with pc? If you enter command fastboot devices in terminal do you get the device number in the output?

“no permissions; see [http://developer.android.com/tools/device.html] fastboot”

That is the output I get.

Are you able to get back to the seller of the device to get reliable information on the Android version installed at point of sale?

It came with Android 11

1 Like

Again, just to try to avoid any wrong turns; do you remember for certain doing this Enable USB Debugging and OEM Unlock?

Yes, I enabled both USB Debugging and OEM Unlock beforehand.

A thousand questions but to help get a clearer picture of the steps that led to the problem…

From the device fastboot screen what is the bootloader version?
Which eos installation instructions were you following? These?
And presumably the last step you got to was to flash recovery, yes?

I forgot the detail, on this device USB Debugging and OEM Unlock has to be done twice!

  1. Since the device resets completely, you will need to re-enable USB debugging to continue.

thank you for pointing that out to me, I must not of seen it.
Am I able to re-enable USB debugging after I’ve tried flashing on the recovery, or am I screwed? I cant boot into the stock OS anymore.

No, your phone is not bricked the original OS is still “in charge”, (but the system and recovery are behaving as if damaged, explaining why you cannot boot, or “go back”).

As said by @chrisrg

you can also flash stock from fastboot.

It may be reassuring to check that the device is charging as expected. Note that the charge state should be >70% to continue.

This would be useful info

Bootloader version: b9-0.4-7265224

yes, I did follow those


I will just drop in this link, for some preparatory reading, Factory Images for Nexus and Pixel Devices  |  Google Play services  |  Google Developers

OK, as usual it may be a combination of things. One may be skipping the step to reset usb debugging after unlocking bootloader and I’ve no idea how to get around that.

Your bootloader version looks like the last android 11 for the device so that was good.

I’m not sure about the given command in the instructions to flash the recovery which says to flash vendor_boot. I’ll have a look at some logs that I’ve got for the pixel5 to see if I can learn anything but this is what I’m thinking…

For the pixel 5 under android 11 the command to flash recovery was to flash boot
Under 12 it’s changed to flash vendor_boot

So I would have expected for barbet and eos it should be flash boot.

But it may not make a difference, I don’t know at this point, and it may solely be missing the usb debugginhg setting causing havoc.

1 Like

ok, Ill try and and sort this out later. Thank you for the help

vendor_boot is one of the dynamic partitions which under normal stock flashing are dealt with when the device reboots into fastbootd (as opposed to fastboot)

In theory one may be able to repair by flashing the stock vendor_boot image but I’m getting outside my area of hands on experience with that. So more research/advice from others is required.

I know that manually flashing in fastbootd can end badly.

1 Like

Just some more general stuff … e-1.1-r-20220628200015-dev-barbet.zip will be built on foundations of the latest manufacturer Android R build for your device … so I suggest you research if there is Android R stock ROM, if it should exist you should flash that next.

In your position, I think I would research how easy are the instructions and what support would be available if you follow the route of going back to stock ROM at this stage.

This might put you in a stronger position for your next install of /e/.

1 Like