Pixel XL fails to wipe

So going through the install steps I get to the point where I’m supposed to format data and do the advanced wipe. In the first case it says it is:
Unable to wipe System
Unable to wipe /system

Then for partitioning details it says
Failed to mount ‘/system’
Failed to mount ‘/vendor’

It seems this is preventing me from installing the /e/ system, or booting into it. Any ideas?

I decided to see if Lineage would work and it did. So there’s something else wrong…

I have tried each of the available /e/ packages for Marlin, but none worked. Again tried the Lineage package to be sure things are going as they should and it worked. So I’m guessing there’s something wrong with booting into the /e/ packages.

If I understand you correctly the wipe step is done using TWRP. This is the same as the lineage installation process. Are you using different TWRP versions for the two installations?

I was trying to imply by subsequent posts that since LineageOS installs fine wiping is not the issue, but something to do with booting. I’ve also found posts on the gitlab page that exactly the same issue. So it’s obviously a known issue.