Poco F1 - fastboot - unable to install TWRP

I want to install /e/OS on my Poco F1.

I unlocked the bootloader, enabled the developer mode again and USB-debugging.
Downloaded twrp-3.3.0-0-beryllium.img and made the md5sum check - OK.
Connected the phone to the PC.

I use LinuxMint 19.2 Mate.
Opened a terminal and “sudoed”.

# adb devices
List of devices attached
** daemon not running; starting now at tcp:5037*
** daemon started successfully*
215ad7b unauthorized

Granted access at the F1 for the PC.

# adb devices
List of devices attached
215ad7b device

# adb reboot bootloader

phone reboots to fastboot.

# fastboot devices
215ad7b fastboot
# fastboot flash recovery twrp-3.3.0-0-beryllium.img

That’s nearly all.
The prompt is blinking, after some time freezes, then blinks again.

I installed /e/OS to a Wileyfox Swift “crackling” and a Xiami Redmi Note 4 “mido”, had no problems.

There should be a message like:

# fastboot flash recovery lineage-17.1-20200627-recovery-crackling.img
target reported max download size of 268435456 bytes
sending ‘recovery’ (26210 KB)…
OKAY [ 0.835s]
writing ‘recovery’…
OKAY [ 2.232s]
finished. total time: 3.067s

To install /e/Os, it is not necessary to flash TWRP, just boot with TWRP.
Try this:
fastboot boot twrp-3.3.0-0-beryllium.img

1 Like

So /e/OS uses the Mi-Recovery 3.0 for updates further on?

To update is something else. If you want to not have to rely on a computer, you’ll have to flash TWRP, but if you can access a computer, you can do the same process with the next update.

Well, this would be the second-best solution.

But the command was not successful.


fastboot boot twrp-3.3.0-0-beryllium.img

downloading ‘boot.img’…
FAILED (command write failed (Success))
finished. total time: 0.000s


The screen turns black. :frowning:

Can you try this command, if you havent, to check if the bootloader is actually unlocked ?

fastboot oem device-info

(bootloader) Device tampered: false
(bootloader) Device unlocked: true
(bootloader) Device critical unlocked: true
(bootloader) Charger screen enabled: true
(bootloader) Display panel:
OKAY [ 0.054s]
Finished. Total time: 0.054s

No, i did not try this command.

But it does not end successful:


adb devices

List of devices attached
215ad7b device

fastboot oem device-info

< waiting for any device >

Now i was successful.

Unbelieveble, the reasons were the USB-Ports.

I was interested in installing A/B-Devices, so i looked at the installation instructions of the Xiaomi Mi A2.


There is a checkbox:

Tip: Some devices have buggy USB support while in bootloader mode, if you see fastboot hanging with no output when using commands such as fastboot getvar … , fastboot boot …, fastboot flash … you may want to try a different USB port (preferably a USB Type-A 2.0 one) or a USB hub.

Tried again - at the USB 3-Port, at both USB 2 Ports - no.
Using the active USB 3-Hub i could install the Recovery.

After this sideloading of the System stopped (error 7) - i tried several times, at various stages.
Then i took a USB 2-Port - then it installed

There is no way to understand it …

1 Like