POCO F1 - Unable to flash

Hi everyone, Im using a POCO F1. I have downloaded the latest /e/ ROM for Beryllium and flashed it via TWRP ( I flashed only this file and nothing else. I store all my ROM files on my sdcard and install them from there in TWRP.
After the flashing is complete, there are no errors.
I wipe the cache and reboot and the device goes instantly to fastboot.
Then I returned to TWRP wiped the system and tried flashing the latest vendor-firmware zip followed by the /e/ ROM. Again I wiped the cache and rebooted.
Same problem again, it enters fastboot.

Am I missing something?

Hi @BentMetal we do have a document here describing the flashing process. Please can you check you are following the same steps.

Yes, but I already have TWRP version installed. I flash my phone with custom ROMs several times a week, so I’m quite familiar with the process. I’ve reread the instructions and don’t see anything I’ve missed. With the exception that I flashed the ROM file from my SD card rather than internal storage, but TWRP showed no errors in the log. I’m downloading the previous version of the ROM now in hopes that it will work. Any other ideas?

@Manoj - I’m still unable to flash your ROM on my phone. The earliest vendor-firmware I could find is 8.1, but it still doesn’t work.
Which vendor-firmware file am I supposed to use and where do I download it from? I would really love to use the ROM but it just won’t install…

Hi @BentMetal if you were on the official Stock Pie ROM previously then you would have a problem with flashing to Oreo. This is an issue with most phones that we have been testing of late. Trying to flash Oreo or older version results in boot loops. Had this issue on my MiA1 as well. So now only use the test pie build :frowning:
The only solution we found is to flash the latest test unofficial Pie builds or revert to Stock Pie.