Problem syncing tasks between /e/OS 1.17 on FP5 and a computer running on Ubunutu

Hi,

I hope I’m posting on the right place.

A few weeks ago, I got my first smartphone, a Fairphone 5 running under /e/OS 1.17. I didn’t have any Google account or data to migrate from a previous phone. I have created a murena account in order to sync data, it works well for my contacts, but not for the tasks.

First I was using the default Tasks app (based on OpenTasks). In the app it shows that a list of tasks is associated with my @murena.io account, but despite this it doesn’t sync. When I’m creating a task on my phone, I can’t see it online (on the murena board in my browser), like a local task, and when I create one on my murena board in the browser, it isn’t shown in Tasks.

I’ve tried to install DAVx5 to see if it would help, and then jtxBoard. In jtxBoard I can see the tasks created in my browser, so there is a kind of synchronization going on, but jtxBoard is not really a task/todo managing app, so I would like it to work on a real app made for tasks/todolists. I’ve also read that it is useless to install those 2 apps since I could normally sync via the murena account.

I’ve tried to install some apps like Trello or Zenkit Todo : the sync worked using these apps accounts, but they are project managing apps, a bit too complicated for my use compared to a simple todo / tasks app, so I’m not satisfied.

Up to that, the device I want to sync my phone to is a computer, running under Ubuntu 22.04, and Trello and Zenkit are not running well under this OS (the desktop programs need several minutes to launch).

Then I’ve tried using another open source software, compatible with Ubuntu : OpenTodoList. It has a feature to synchronize, but it asks me to give the Server Address, which I don’t know.

So, to this point, I can see 3/4 ways you could help me :

  • tell me how to make it work on the standard, Tasks app,
  • give me the name of a simple Todo app, running well both under /e/OS and Ubuntu 22.04, with a simple way to sync,
  • give me the Server Address so that I can try with OpenTodoList,
  • maybe find another way to help me out from this problem.

Thanks in advance for your advises, I’ve spent some hours trying to make it work alone, and reading some documentation before posting my question here.

Unless this point, things are working well and I’m happy to use this FP5 with murena /e/OS.

Welcome to the forum, malomorvan.

I cannot give you a solution, but I hope that someone else can answer one of your questions.
I just wanted to note that I also have some synchronization problems with the Tasks app: If I add a new task, the synchronization under Android Settings > “Accounts” > (choose the murena.io account) > “Account sync” is shown to be stuck somehow. If I go to “Accounts” > (choose the murena.io account) > “My account” > “Settings” > (choose murena.io account) > select tab “CALDAV” and press the refresh button in the lower right corner, the synchronization happens. This is not the case with calendar entries etc. where the synchronization seems to work.

Thank you Tentos, I’ve tried this already, and it’s not enough for the tasks to sync.

I’ve noticed something : on murena.io, the tasks don’t seem to be considered as tasks, but rather as appointments : the tasks lists’ names appear on the agenda, and I can export them to the .ics format (which is a format I usually know for calendars and not for tasks) : could this be a reason ?