Problem with Advance Privacy and the default browser

Advance privacy does not work with “private dns”. If i want to turn on advance privacy, i have to go to setting and turn off private dns and then turn on Advance privacy. So i don’t use it.

Bromite has terrible adblock, almost all pages i visit are riddled with ads. I currently use firefox with ublock origin, I haven’t seen a single ad eversince.

In conclusion, Make advance privacy work by temporarily disabling private dns and enabling it when Advance privacy is turned off. Make firefox or anyother browser which supports web-extensions as the default.

this would qualify as a bug if reproduced, couldn’t find something like this at Issues · e / Backlog · GitLab - will test this