Problem with installing to oneplus 9 pro

Hi! I was trying to install e/os on my new phone, however now I am unable to boot to the recovery after flashing it. What could be behind this issue?

Quick update. I did what was mentioned in OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #18 by eps1 post#8. It worked and I got all the way to booting the os, but it wont boot. It just ends up in qualcom crash dump mode. What should I do now?

So this is just what happened next in the example we are following OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #14 by GaelDuval

Speculation this has happened as you device got contaminated during the earlier failure which happened following install instructions.

What to do now ?

  1. Some would revert to Manufacturer’s stock ROM at Android 12 and start again.

  2. The method used next in our example was to overwrite all partitions which may have been at risk of being contaminated.

Do you have a Manufacturer’s stock ROM at Android 12 ?

I don’t think I have.

I did not find the source for Manufacturer’s stock ROM at Android 12 quickly, searching for OOS 12.C65 – can anyone else help ?

What I have bookmarked is but this is overkill for your situation.

this says it is 12.1, but could it still work?

I think that is an update and not a full ROM.

I have this link but it is now updated to Android 13, T. Previously I have not been able to install Oxygen updater, but that updater is worth a try, perhaps if you can access it.

Do not try 13. You must only use 12, is a link for information, sorry I have to be somewhere else ! Sorry.

Alright, I will try 13 then. Ah ok, I won’t try it XD. I’ll try figure something.

edit: Tried downloadin oxygen updater on my other phone, but it will only let you download the latest update.

Have your read OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #16 by GaelDuval ? Just in case… Only available as an OTA update, but you can extract useful content from it.

So how does this work? What I need to extract from it?

You can see all the .img firmware files that are flashed on both A and B slots, using fastboot. They are the most important files to ensure compatibility with /e/OS builds based on Android 12.

Can I get them extracted with payload-dumber?

edit. I have all the images now ready to be flashed. You mentioned that one needs to be in fastbootd mode to flash them. So I enter there by typing command: “fastboot reboot fastboot”?

I had read the post in the past … but unfortunately, rushing to an appointment, I had not internalised that this link does contain all that’s needed after extraction with payload-dumper-go. contained all one needed (if that is the case, I never opened it).

Sorry @eps1 if misled you. In an Xiaomi super partition device, the fastboot screen changes to fastbootd when you run fastboot reboot fastboot. So I expect you will get visual confirmation.

Hello! I tried “fastboot reboot fastboot” but it failed to boot back into the fastboot menu. Instead it tried to boot the broken e/os. Did I do something wrong or is there something else wrong with my phone?

With an understanding of the button presses are you able to control the device ?

If you lack control, please try to explain exactly what does not work.

… so it got to fastbootd once ?

So, I am able to boot into fastboot menu. I did “fast boot reboot” while in the fastboot menu, but it didn’t boot back to fastboot menu. Instead it tried to boot the broken e/os. I am also still able to boot into that menu, however the reboot doesn’t reboot it to fastboot menu directyly and I have to shutdown the phone from the crash dump screen and reboot manually to the fastboot menu.

I may have missunderstood something here. Is fastbootd differen from normal fastboot menu somehow?

Yes fastbootd moves moves fastboot into userspace. They are not at all interchangeable.

You really only move to fastbootd to do a job. A super partition device like this is quite fragile especially when corrupted.

So you can leave fastbootd with shutdown.

There is no reason why it would – reboot is expected to reboot system.

I cannot be sure whether you have seen something to tell you that you have entered fastbootd.

I actually might have overlooked something here, after booting back to fastboot menu manually the reboot process ended like this:

./fastboot reboot fastboot
Rebooting into fastboot OKAY [ 0.003s]
< waiting for any device >
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.

could this be of any help determening why I wasnt able to boot into the fastbootd or Is it just a consiquence of it not being able to boot back into the fastbootd. And also what can I do if it is correct what it says there.

Edit: Wait, now it worked, Im in fastbootd??? wtf?

Alright, I flashed all the images succesfully. All works now! Thank you so much for help, could not have done this without you :slight_smile: .

thank you. @aibd & @GaelDuval