Problem with offline/power off charging on a Z3 Play

Hello, I have a weird issue; when I power off my device (XT-1929-6, unlocked and with /e/os) and I connect the USB cable to charge, the phone vibrates and goes to the charging screen and it gets stuck there. Even though the phone still charges, there is no animation or indication of whatsoever.
Pressing and/or holding the power button does nothing. The only way to get out is holding down power+volume down to force a fastboot reboot and then start normally (On Android it charges normally).

Sadly, I did not tested it while on the stock rom (pie) nor did I notice/tested before flashing a custom logo from this XDA thread

Things I have tried with no solution;
Using different chargers and cables
Flashing with; “fastboot flash logo”, “fastboot flash logo_a” and fastboot flash logo_b" commands
Flashed numerous logos, from various stock roms (oreo and pie). Also tried making my own logo, with works and flashed correctly but the issue persists.