Problems after update from 0.1 to 0.5 on Xiaomi Mido

issues-for-gitlab
blisslauncher
xiaomi

#1

Hi, after OTA update form 0.1 to 0.5 at the moment, I realized that:

  • at the first start of 0.5 I chose QKSMS as the default sms app instead of Signal but the sms were not imported into QKSMS. I haven’t lost them because they are still in Signal. So I set Signal as default but the sms icon always opens QKSMS…
  • I have lost the Mail configuration… there were no more mail accounts that I had in 0.1. Also the mail /e/ was reset, created as new, as if it were a clean installation.
  • the order of the apps in the screens has changed by mixing system apps with installed apps in alphabetical order.

For the future it would be better to be more precise about the consequences of updates.
Thank you
Bye


Xiaomi Mido: LineageOS 14.1 EOL
Yalp unavailable since last update
[PLEASE READ] Important message for users of Moto E, Moto G, Nexus 4, Nexus 5, HTC One M8, Wingtech Redmi2!
#2

I also lost root access (addonsu)…


#3

After today’s OTA update (e-0.5-n-201902213459-dev-mido.zip), only the phone and camera icons remain at the bottom. Missing sms and browser… can they be inserted? I haven’t found the way…


#4

Hi @VitTh this issue has been resolved and the fix should be available in the next builds. Sorry for the inconvenience.


#5

hi, thank you. I hope the launcher will be customizable in the future.


#6

still remain in e-0.5-n-201902233562-dev-mido.zip (except Mail)


#7

still remain in e-0.5-n-201903013788-dev-mido.zip (except Mail)


#8

@VitTh please can you elaborate what is the issue you are still facing in the mido builds? Are you not able to place icons to the task bar.


#9

Hi, I’m sorry, I forgot to write that the only problem that remains is just that after each update via OTA, I have to re-flash addousu-14 to get root access


#10

Hi @VitTh I have not used addon-su as I do not need to root my phone so not sure about this particular case.
Assuming that builds will overwrite it all the time. If I remember I had flashed TWRP on top of /e/ and then did an OTA update and everytime it got overwritten.
The behavior is the same with Lineage ROM as well. Step no 10 https://wiki.lineageos.org/devices/tissot/install for manual flash.
Have you faced this issue of addon-su being overwritten when using LineageOS4MicroG ROM’s?


#11

Hi Manoj,
OTA updates overwrite LOS Addonsu since 0.5 but it never happened with 0.1
I have never used alternative ROMs except /e/ (with Xiaomi Mido) (the first commandment… :grin:)


#12

lost LOS addonsu again with OTA e-0.5-n-201903053915-dev-mido.zip


#13

lost LOS addonsu again with OTA update e-0.5-n-201903114123-dev-mido.zip


#14

Have you tried how Magisk behaves with OTA?


#15

no, i haven’t yet tried. but it didn’t happen in /e/ 0.1. I’ll point it out. I think it should be fixed. But it is not a problem flash every time addonsu


#16

The issue of addon-su is being worked upon. A fix was checked in the oreo branch and should be available in next couple of builds. Work on the nougat is in progress - do not have an ETA as yet. @VitTh have you raised an issue for this in gitlab?


#17

yes https://gitlab.e.foundation/e/devices/xiaomi/proprietary_vendor_xiaomi/issues/2
thank you