Problems building Nougat for trltexx

and this will make the build script look into roomservice_a.xml also? Just wondering …

how about just chmod a-w rommservice.xml ?

All build scripts are looking in .repo/local_manifests and using ALL .xml files.
EDIT: You can have 10 different .xml in that folder. they will all use as long as there are no duplicate lines in

oh well, docker killed roomservice_a and replaced roomservice even though chmod a-w.
now working with your HOWTO …

1 Like

ok, here’s my feedback so far …

  1. one should be recommended to use /home/username/android as start directory … nevermind.

  2. there was a missing SPACE in the roomservice.xml in line 5.

  3. only after coorecting that the xml stopped being replaced even in your method. But still:

  4. Looking for dependencies in device/samsung/trltexx
    device/samsung/trltexx has no additional dependencies.
    build/core/ *** Can not locate config makefile for product “lineage_trltexx”. Schluss.
    build/core/ *** Can not locate config makefile for product “lineage_trltexx”. Schluss.

It appears another file (the makefile) is missing …

Yeah, I think there are still missing kernel sources. Sorry, but I don’t have more time to dig deeper :frowning:

Thank you very much indeed … you have helped me a lot to get at least some basic idea what I’m trying to do here!

one more thing please, if the kernel sources were here:

where in the tree would they go to? Would like to give that a try …
Vielen Dank!

I’m not giving up …
I managed to get all the sources in place and reached doing breakfast without errors.
croot and brunch gives me this:
/home/joachim/android/eOS/external/golang-protobuf/proto/buffer.go:11:2: can’t find import: “
I assume some part of go language is missing, even though I downloaded protobof-go and placed it in android/eOS/external/golang-protobuf
It also has the /encoding/prototext dir with *.go scripts in it …
Any clue? Anybody else maybe? Thanks in advance …

That’s always the best and it will make you to an specialist :smiley:

I don’t have any go sources on my Mint building machine
which OS are you using?

Ubuntu 20.4 LTS …
even trying Chinese: did the git clone, copied the files …
gives me this although the files are there …:
go install***
can’t load package: package cannot find package "" in any of:
/usr/lib/go-1.13/src/*** (from $GOROOT)
/home/joachim/go/src/*** (from $GOPATH)
tried both of course …

for me it sounds more, that you have issues with source sync.
I would prefer to make a new ‘repo sync --force-sync’ to check if the sources are complete downloaded.

And by the way, I have had a lot of trouble building, because my system was to new. That’s way I’m going back to Mint19. The best building OS is UBUNTU 18.04.

EDIT: And I think I have written before: try building a supported device

Do you know what happened with docker “”? I always got the “manifest for not found:” error( The community docker tag correctly work.

Hi @sprainbrains You will find This is the correct image location here

Hi @Manoj. What is the correct value of <ota-url>, for unofficial builds? Thanks

If you don’t have set up your own OTA server, you can remove this line.

I never use it. keep it blank. You can check the details of a build I made with the community docker image here

being OP of this thread I’d like to close the topic. I am not anymore trying to build /e/, instead I am very much enjoying my brand new FP3. Again thanks a lot to everybody who tried to help me. Still, in case anyone runs into a /e/-build for trltexx, please let me know.

As requested closing the topic