Problems installing /e/ on my Fairphone 3


I get the following errors by sending “fastboot -w” to my unlocked fairphone that was not in use before and has no data:
wiping userdata…
Invalid erase-block-size 512: must be a power of 2 and at least 4096.
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.44.1 (24-Mar-2018)
/tmp/TemporaryFile-dTzSKp: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

Somebody a tip what to do?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What Os did you have on the phone before flashing? Maybe flash the latest FP software first, go here for instructions.

That is a problem with the fastboot executable, see for example:

1 Like

Yeah, this is known, see @Ingo_FP_Angel’s post for the solution.
Sadly, /e/ didn’t want to make this more clear, see Add a warning to /e/ install instructions to avoid fastboot -w failing?

Hi guys,
following the instruction of Fairphone to unlock the bootloader I updated the Fairphone OS/Android before starting, this was not the reason for failing.
The hint to install adb and fastboot according the instructions was great, afterwards everything worked OK, the installation of /e/ was successful :smile:
Thanks alot.

1 Like

After I ran into the same problem as the topic starter did. I removed the fastboot from my computer and did the following steps:

On Linux

  1. Download the [Linux zip] from Google.
  2. Extract it somewhere - for example, ~/adb-fastboot .
  3. Add the following to ~/.profile :
if [ -d "$HOME/adb-fastboot/platform-tools" ] ; then
 export PATH="$HOME/adb-fastboot/platform-tools:$PATH"
  1. Log out and back in.
  2. You may also need to set up udev rules: see [this repository] for more info.

Unfortunately now my output is

$ fastboot devices#

Der Befehl 'fastboot' wurde nicht gefunden, kann aber installiert werden mit:

sudo apt install fastboot

Which means, that fastboot is not found, but can be installed by the command line.

In ~/.profile it says:

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/.local/bin" ] ; then

if [ -d "$HOME/adb-fastboot/platform-tools" ] ; then
 export PATH="$HOME/db-fastboot/platform-tools:$PATH"

I think there is a typo near the end (missing “a”):

export PATH="$HOME/db-fastboot/platform-tools:$PATH"

Should be

export PATH="$HOME/adb-fastboot/platform-tools:$PATH"