Problems Sending/Receiving MMS and Group Messages

Sure. … It is “240.”

thanks for mnc clarification. The Lineage+/e/ apn entries are aligned with what the Ting APN docs propose, or am I missing something?

What private DNS do you use when the setting is active? ipv4 or hostname (the latter is a good idea btw)?

I made a sanity check with my own carrier (Vodafone DE), enabled private DNS + mms sending, it was possible.

If you want to dig deeper, enabling adb root in the devoptions and installing tcpdump to see which packets go unanswered on the enabled private DNS will maybe give a hint

When compared to @aibd’s extraction above, yes (although it also shows a separate MMS APN, which is no longer valid for Ting’s new X3 SIM, if I understand).

When compared to the Gitlab link you posted, no.

I’m on .018-q unofficial for XZ1 Compact, so I’m not sure which APN settings are built in. I do recall that I originally had to create the Ting Data APN manually in order to get internet connectivity, though.

I was using “9.9.9.9” as the preferred DNS resolver, and had data, but no MMS.

Must depend on carrier plan, cause i can’t see the switch, even with data off and wifi connected
in France using Sosh provider ( owned by Orange ) my revokable plan include voice calls & SMS/MMS unlimited, data LTE/4g speed reduced after 70go/month = 25€ + 5€ ( for a second SIM, that use the same call number as the first one for voice calls, but a different call number for SMS/MMS ). using Orange network and Orange APN

No, I think you have to exclude my three European (German) options.

Say we assume the other two of five in the source might be USA, let’s drop in those two (from the source apns-conf.xml), and you have mnc=240, #2 has it - or not? If the source is not up to date, well, Ting’s job again: APN และ CarrierConfig  |  Android Open Source Project.

<apn carrier="Ting" mcc="310" mnc="120" apn="n.t8.ispsn"
type="default,supl,mms"
mmsc="http://mms.plspictures.com" mmsproxy="68.28.31.7" mmsport="80"
protocol="IPV4V6" roaming_protocol="IPV4V6" />

<apn carrier="Ting Data" mcc="310" mnc="240" apn="wireless.dish.com"
mmsc="http://wholesale.mmsmvno.com/mms/wapenc"
protocol="IPV4V6" roaming_protocol="IPV4V6" type="default,admin,fota,mms,supl,hipri,internet,dun"

Thanks, or your (…) device?

I can’t remembrer details off my fisrt s7edge device
Mostly experienced on relatively ancient devices :
Samsung Galaxy s4mini, s4, s5mini, s5,
android 7, 9, 10, 11

You’ve lost me there. Ting is a U.S. MVNO. (And you posted the Ting info in your extraction.)

Well I am sorry, I did not mean to deceive you! I was really demonstrating the method I used to extract some data from my device. Still partly in answer to

… well with global modifications perhaps?

I thought Ting was a USA outfit too, I extracted

numeric='310260'

from [mcc=“310” mnc=“260”] quoted,

and so on … then found Ting has a German footprint, but not a USA one on my device.

Thanks for the clarification. I think I understand what you’re saying, although I don’t have any experience with adb.

I suspect it’s because Ting is one of the few U.S. MVNOs that has international roaming agreements.

BTW, I said earlier that Ting runs on T-mobile USA’s network, but they also use Verizon’s network for customers that don’t have good T-mobile coverage at their home. I don’t know which APN settings are in effect in that case. Possibly the same as the published X3 settings. I wonder if that could also be reflected in the source APN file…? (But that’s neither here nor there, really.)

P.S. I didn’t mention it in my original post, but I had the same issue with Mint Mobile (another MVNO on T-mobile USA). :confused:

as using tcpdump can be daunting - can you go through some of the popular public resolver to cross check?

Setting an ipv4 will disable your private DNS in a network when only ipv6 is routed. Quad9 offers hostname resolution, this will give you reachability on both stacks. So if you test with quad9, cloudflare, google… besides the easy to remember ipv4s, can you also check with the hostname? For quad this is dns.quad9.net or one.one.one.one for cloudflare, dns.google for the 8.8.8.8 ones.

I’ll try some of those… but Evil Corp (Google) will not be one of them. :rofl:

Edit: Well, the host names for Cloudflare and Quad9 don’t help, even after reboot; MMS is still inoperative. Switching back to network-provided DNS gets MMS working again after reboot.

To be precise, I now have Private DNS set to “Automatic,” and the setting “Allow to use DNS from network provider” enabled. I’m not sure if that engages Private DNS whenever possible. (Does it…?)

Quick, late question. Do you use a VPN or anything like that? Seen no mention of it so probably not.
Depending on ROM, I’ve had issues with group and MMS messages but it was apparently due to the use of VPN or DNScrypt or whatever.

The following is a big what if but wouldn’t hurt to try.
In my case, it would seem the IP address of my mmsc address was being changed, causing problems with MMS.
So for instance, my T-Mobile mmsc has the hostname of mms.msg.eng.t-mobile.com. While using a VPN or alternate (Private?) DNS the IP would be 208.54.151.170 (public).
Found by going into a terminal and using ping -c4 some.hostname.com.

Disabling the VPN or turning Private DNS off, reboot to flush DNS cache and ping the mmsc hostname again.
Now the IP is 10.188.239.158. I would take that or similar address and put it into the MMS proxy field of my APN. MMS would then work. Then I would reenable VPN or Private DNS or whatever. Still worked.
I say similar because the phone I got that IP address from is using an address that ends in 160. Seems to change after awhile.

But anyway, like I said, it wouldn’t hurt to try this angle.

1 Like

Not currently. I do use TrackerControl, which uses the VPN slot, but turning it off has no effect on my issue. I thought of that. :wink:

Allowing network (carrier) DNS is the only thing that brings back MMS functionality for me.

Sorry, my post was premature. I added more content.

1 Like

So, was browsing through the DivestOS FAQ and saw this little bit. Kind of fits the situation maybe?


Why haven’t you completely changed the default DNS servers?

Currently Quad9 (after trying many other public resolvers) is used for DNS fallback and for tethering. Switching it by default for cell would break VoLTE, SMS, MMS, and Visual Voicemail. And switching it for Wi-Fi could potentially break access to some LAN devices.


2 Likes

@Taurus my setup is Mint Mobile, ProtonVPN (wireguard), and NextDNS, which I believe was proposed when you and I were trying to figure out the S9 issues. I haven’t had as many MMS issues with that (a few where I know I didn’t get group texts), but most of my trouble seems to be linked to QKSMS itself not wanting to send the full size photo. If VPN and DNS is linked to the issue, this is the first I’ve heard of it. Hope that helps.

1 Like