No downloads possible - phone behaves strangely

I describe a similar behavior in the official case I made two months ago. Feel free to add informations there.

Interesting is that you also say some apps work over network connection and others do not, at the same time. That’s what I also remember.

1 Like

I’d like to as there is so far no assignee to the issue - it is only impossible for me to register and log in, as GitLab doesn’t like my mail-adress out of strange reasons:

1 error prohibited this user from being saved:

  • Email is not allowed for sign-up. Check with your administrator.

Just dunno what my admin got to do with it. It’s myself anyway.^^

Now I keep wondering how I might get the prospected upgrade of the OS while there is no Internet available for the device.
Can one upgrade via ADB?

Right now I am again in my WLAN, have a IPv4-adress for the FP3.

The router says it has a signal strength of -70dBm and an actual data rate of 390 / 6 Mbit/s.

The device says that it is connected to my WLAN and has no Internet.

It connects via Warpinator though, and this is how I transported this screenshot:


While setting WLAN as connection, it gave me a popup to tell that there were no Internet available…

WTF?!

After a reboot I always had Internet. And it did always really work then.

Just rebooted - no Internet.
Flight mode on/off - no Internet.

Router says it is on IPv4, has -50dBm signal strength and 53 / 2 Mbit/s.

GRMBL.

So am I.
To no avail.
sheesh

May there be #somebody to take care of this?

I am sorry but did you read the link? It contained the solution! :slight_smile:

2 Likes

And if you don’t want to scroll down one page from that post, the solution is…

1 Like

Oh, sorry.
I didn’t realize it was a link, took it for a citation and commented.

Sometimes I’m lazy, right.
My screen and settings require no scrolling anyway, but I had to call the link in the first place…

Thank you.

1 Like

As there are still no downloads possible and no Internet connection (though some things work) for days I’d like to check whether there might be a settings problem or a system mistake.

Is there any structured checklist available for Android 10 to check step-by-step?

Now, we had a system update and my FP3 is on /e/OS 0.21-20220122158537.

I still have no Internet and BTW I wonder how the download of the system update was done as F-Droid or browser always keep telling me they had no DNS.
Anyone able to explain?

So far I have only one provider (telekom.de) and the settings seem to fit - mobile data on, VoLTE on, only there is but one single APN (Telekom MMS (internet.telekom)).

Even when I’m in my very own WLAN I do not have access to the Internet, the router says it is active on IPv4 and prioritized (signal strength: -66dBm, max. data rate: 433 / 433 Mbit/s, actual data rate: 433 / 6 Mbit/s, WLAN-Standard: WLAN-ac / Wi-Fi 5, frequency band: 5 GHz, channel width: 80 MHz…), it only doesn’t seem to know as F-Droid shows no “News”, no categories, and no search results.
The browser can’t put up a website, the diagnosis is still the s(h)ame:
DNS_PROBE_POSSIBLE

Please, any hints to find the problem.

If you directly request a well known IP-Address you don’t have a domain in it, so you probably don’t need a DNS for resolving. My guess.

What is in your DNS settings in the OS?

BTW: The DNS settings are also to be used in the same way when the network is mobile and not wifi. When they work on a mobile network they must also work on a wifi.

I use “Network DNS”, and private DNS is “on” and “automatically”.
Worked before.
A change to 9.9.9.9 doesn’t solve it.

And it keeps not working either in LTE as well as in WIFI.

I switched off “Use network DNS”.

In the DNS option below I wrote 178.9.93.198 which was mentioned somewhere here in the forum in another thread as a good DNS.

Before I got app-updates with “Apps”, download and installation worked for all three.

F-Droid is still deaf and dumb, as well as the browser.

Magic Earth actually (and astoundingly) seems to work.
At least it dated up the maps and I could possibly try it out.

Your suggestion is a DNS by vodafone (D2).
Would be kinda strange to use it with D1.
But I do not leave anything untried.
Result:
DNS_PROBE_POSSIBLE

So, I returned to 9.9.9.9.
At least I have a road assistant this way.

Is there really no suggestion to check for DNS methodically?

Just to rule out it’s related to some installed app, did you try to start in safemode?

1 Like

First, I am back online finally.
With anything I desired (F-Droid working and updated, Orbot installed, new browser…).

Yesterday I was so desperate to make an appointment with a Telekom technician for today.

This morning I tried “Safe mode” but had no Internet either, same DNS_PROBE_POSSIBLE-thing in Brave, no F-Droid working (empty news (“No installations for three weeks”), empty categories.

Switching back to normal mode there were some issues, as you might expect.
So, I had to fumble with settings, got my Launcher right, found some contradictory ones (e.g., a VPN-setting that said, it required Orbot, which was not available) and the like.
After this I pocketed the FP3 and headed for my appointment at Telekoms.

In the metro I realized F-Droid downloading package sources, which lasted a bit as there was about some time to cover. Then it presented itself the way it had been at the beginning: Lists of software instead of empty pages.

The appointment was quite disappointing, the man was unable to help out, had seemingly no idea what a DNS does and how to check it. Anyway he tried to sell me things I don’t need.

Since F-Droid was back online I started downloading Firefox Nightly, just to check.
Installed it, called it and - guess what? - it worked.

Now I got bold, downloaded Orbot, ordered any app to connect through its VPN, gave it a fresh start, and all is still working as intended.

Looks to me like there had been some setting conflict, sadly I can’t say which one it might have been. There were quite a few after restart…

In any way the road via Safe mode solved it somehow, maybe the basic inconsistency got exposed.
So, I give you “solution” credits.

Still I wonder whether there is a structurized way to check for dependencies of DNS.

3 Likes

Please to hear it resolved for you. I too would like to see a way to

check for DNS methodically

but many other things are involved! For instance, on a quite different subject, Problems Sending/Receiving MMS and Group Messages - #37 by marcdw.

Proposal: [Getting started] DNS

:construction: This post is editable, anyone please feel free to contribute. As I understand it so far … starting from Settings > Network and Internet > DNS … I see these options …

1. Use network DNS

2. Use a chosen DNS provider

3. Set your chosen DNS provider.

… as I understand it 9.9.9.9 is pre selected by /e/ if you opt out of “Use network DNS”. … but it might be useful to see this post edited and expanded by others with experience! (Thanks + kudos @smu44 for additions.)

Known hazards and workarounds

Please be aware that some filtering tools (i.e. TrackerControl) will require to deactivate Private DNS.

As I understand it … Your choice of DNS has to be able to cooperate with your mobile data carrier, your home isp, your home router, any combination of the above if working though any outside or “unknown” network, any app you are using.

You could validate your config against some online tools,try Router Security | Test Your DNS Servers.

Encrypt your DNS queries on /e/OS system-wide

Question and answer

Q. Is it a good starting point to " Use network DNS" for say 24 hours at first install to see if all works ok?
A. (proposal #1 by @smu44) : yes, some weird operators won’t allow some operations if not using their DNS.

Q. Is 9.9.9.9 the right choice for me?

Q. At “First run Wizard” does the user Select or will “Use network DNS” or “Preset 9.9.9.9” be used, without user intervention?

Q. I want to disable Private DNS, but setting is missing. How can I ?
A. Please see Private DNS option missing from Network & Internet Settings (#3680) · Issues · e / Backlog · GitLab

3 Likes

Very nice post @aibd ! :smile_cat:

It would deserve a dedicated thread :wink:

PS : sorry for the quick’n’dirty edit, please feel free to make it better

PS2 : just found Encrypt your DNS queries on /e/OS system-wide

2 Likes