Problems sending SMS and mobile data when roaming - FP4

Hi all!

A proud owner of FP4 (bought with e.os preinstalled) here. Otherwise very happy with the phone, some minor annoyances, but that’s for another post… :slight_smile:

I took it out of the country for the first time now and a couple of things don’t work when roaming:

  • I can’t send text SMS messages (but can receive them fine), and
  • mobile data doesn’t work; it connects, but I can’t send or receive anything.

I have tried adding the APN manually, but it doesn’t get saved (or, to be more precise, it doesn’t show in the list after I save it).

I got an SMS from my provider urging me to accept setting that I was supposed to get from the foreign provider, but was never offered this option.

Roaming worked flawlessly with the same SIM card (and provider) in an Android phone half a year ago.

Probably not related, but I’m using NetGuard and filter network traffic. Disabling it temporarily didn’t help.

Can someone please suggest how I can make roaming work? I’m running out of ideas… Or is roaming simply not working in e.os?

hey. Last week I was out of my country and roaming worked as expected. And yes, I have FP4.

1 Like

One reason that might happen … do you have a clear wifi connection while you try to save the APN. I believe the device will try to confirm with a database that your new setting is on the database before allowing the “save”.

Ofc, as this is a roaming problem, the issue could be quite different!

1 Like

Thank you for the suggestion! I have tried again (reset the APNs and insert again EDIT: while on good wifi), but no luck - the new APN simply disappears. What is interesting is that it disappears only when I set non-default MCC and MNC numbers… Weird.

I did also notice that I can’t manually select the mobile network because the list is always empty… Automatic selection however works and the signal strength is great. (EDIT: solved this part by selecting a different Preferred Network Type, it now shows the providers)

I’m on latest version (1.1) if it matters… I’m guessing I have disabled something I shouldn’t have?

Thank you both for your help! It turns out that my provider sends APN settings through some notifications which (I think) use Google cloud. No G - no settings… They have now sent me an SMS with the correct APN and it works. :grinning:

The reason I could not enter APNs is that android “helpfully” hides all non-applicable entries. The MCC/MNC must actually match my provider, not the foreign one… So one can only get the APN data fron their provider.

Anyway, all works now, and I have learned a ton. Thank you!


This topic was automatically closed after 30 days. New replies are no longer allowed.