Problems with custom recovery (TWRP) Galaxy S7 “herolte” SM-G930F

Hi all . Please tell me if there are any problems with custom recovery ?

I used TWRP (as written in the instructions ) after installing the ROM, I tried to enter the Recovery mode and saw that the recovery was /e/OS. I have nothing against this recovery, I just don’t understand why I don’t see what I installed.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I believe installing /e/ automatically installs the /e/ recovery as well, unless you explicitly choose not to. This overwrites TWRP. So no problem here, just default behaviour. You’d have to reinstall TWRP if you want to use it instead of the /e/ recovery.

I see two possible cases :

  1. If you apply a system update without uncheck the recovery update option in settings, updates, menu, preferences

  2. If During the /e/OS first boot setup wizzard, you should have validate a recovery update

You still can reinstall TWRP using Heimdall or Odin. (don’t forget this time to uncheck the recovery update option in settings, updates, menu, preferences…

Édit :

1 Like

Hello . Thank you very much for your reply.

I’d like to clarify as I don’t understand which part is being referred to. Here are my steps:

  1. Switch to Download mode
  2. this command I install TWRP $ heimdall flash --RECOVERY recovery.img
    By the way, I wanted to pay attention that the latest version and a few more penultimate ones do not work, after installing them, my phone goes into constant reboot mode and cannot load the TWRP menu, so I use version twrp-3.2.1-1-herolte.img
  3. After I installed TWRP, I go to the WIPE section, put checkmarks everywhere except MicroUSB and USB OTG, then Swipe, reboot the phone, like everything is OK
  4. Install ROM
  5. After installation, I try to enter Recovery mode and see /e/OS recovery??

Additional Information .

All this happens without internet connection, I don’t download any updates so I do everything offline.

Where did I make a mistake or did not uncheck the box you wrote about?

So, you problably have checked a recovery update box during the /e/OS first boot setup wizzard

Could you clarify what flag you are talking about, I can not understand))? In TWRP?

No, during the setup wizzard the fisrt time you boot into /e/OS.

Okay, now I’ll try. Thanks for the advice

I reset the phone to factory settings, went through all the steps again before starting the phone and did not find an update or restore point …

Hello . Thanks for the answer . You write that / e / overwrites TWRP. Okay, what do I need to do to prevent this from happening?
Reinstalling TWRP a second time did not help the situation is the same, when I enter the RECOVERY mode, I do not see TWRP.

What piero wrote does not work. Perhaps he made a mistake and thought that I was connecting to the Internet after installing the ROM

When you say “Reinstalling TWRP a second time”, do you mean you installed it after you had installed /e/?

I mean that I cleared all the partitions (if this is not done, then / e / is always loaded) after that I installed TWRP, then I installed the ROM.

Thank you very much for the screenshot, I understand you, but it does not work. Now I have the latest ROM installed and when I try to enter Recovery mode, I see / e / recovery instead of TWRP and this is strange since I installed the ROM using TWRP.

Try installing TWRP after the ROM has been installed. Make sure to boot into recovery immediately after installation, or it might be overwritten again. If that works, with every update of /e/ make sure to untoggle “Update recovery” as piero mentioned.


Thanks for the advice, I’ll try it now.

Now everything worked. It would be great if the site admin left this post and did not delete it for those who will face the same problem.
I did like this:

  1. $ heimdall flash --RECOVERY recovery.img --no-reboot
  2. To turn off I had to press the Power button and the volume down button. (Separately holding the power button does nothing …)
  3. Next, I booted into Recovery mode, clicked “Reboot” and selected “System”

I was wondering after loading / e / I will again see the / e / recovery, but no, this time TWRP loaded))

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.