Problems with Oneplus 7 pro


I have a big problem with my newly buyed Oneplus 7 Pro.

I have flashed the phone with /e/OS 0.14 and today updated it to /e/OS 0.15.

The problem is the SIM card, like you can see at the fotos attatched. The SIM card does get found in the phone, but the phone doesn´t find any cellphone network. If I try to manually deactivate search cellphone network automatically and search manually for them, the phone hangs up in a loop and the app “settings” has to get shut down via taskmanager.

The phone is a GM1910, this is a Chinese version, but this verison normally has no problem to find european SIM cards. For me it looks like a software issue.

Has anybody ever had this case reported?

Maybe there is a file you can provide me or something, that I can flash with the e os and then the SIM card connects to a cellphone network.

My cellphone provider is Hutchison Drei!

I live in Europe/country: Austria/city: Innsbruck/state:Tyrol.

Thank you very much for your help!

Best regards

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I am very sorry for upload the fotos everytime in a new post, I am only allowed to post one foto at once as a new community member.
I would be pleased if someone could help me with this problem! Thanks very much for your help!!!

Was it working before flashing /e/?

Hi Ludix,

thank you very much for the fast reply!
This is the problem…I didn´t try… :see_no_evil:
I took it straight out of the box and flashed it…now I know better…I know I´m an idiot! :woman_facepalming: :man_facepalming:

I don’t know much specific about OnePlus phones, but I think you can find the original ROM online.

It’s a good idea to update the phone from the stock ROM before flashing /e/, so I’d recommend trying that if there’s no other suggestions. In the same step you can try the SIM functionality on stock OS.

Could this be the same issue reported in GitLab?

1/ go to settings menu
2/ go to internet menu
3/ clik on sim menu
4/ try to change the color of sim and valid a new color
5/if nothing appear, try with a new sim
6. If nothing appear,try to flash a old version of E.

I had a problem similar and sometimes i change the color of sim in the menu


Hi Pierre :slightly_smiling_face:

Thank you very much for your response and help!!
Unfortunately it didn´t work out! I have tried with 10 SIMs now and nothing helped. I also tried to set the colours like you described.7



Hi, try with a other os, lineage os or a old version of /e/.
If the problem is material, i don’t see how to repare a sim system, it’s easy to change a camera etc. But that -.-.
After find a solution to send back the phone to the seller.


I have some news, I have managed to connect to the mobile network like you can see in the foto 1 attatched. But unfortunatelly it didn´t last long, because I took out the SIM card and put it back in and then the phone didn´t manage to connect to the mobile network again :confused: I first flashed the first version of e os what was available for this phone at the e foundation homepage.
It really looks like, that the issue is related to the phone, otherwise I cannot explain this behavior.

I have one essential question left**:**
I really need WLAN-calling. I have a foto attatched (Foto 3). This screenshot was taken when the SIM was recognized once in SIM card slot 2.
But I cannot find a WLAN- calling icon/symbol. Is it possible with e os to get this function on the Oneplus 7 pro? The phone itself supports it and mit mobile network provider either! Or is there something what to care about to activate it?! I am just wondering why there is no WLAN-calling icon at the top of the screen.

Thank you very much for your help!!!



Hi tantalus

That i know and with my little expérience with installing and using /e/ .
You have a lot of phones compatible with /e/.
You have différentes images to flash.
Some images are /e/ versus oreo or pie or Q.
It depend of the process of developping.
A lot are alright and sometimes you have some problems.
It’s not fix, it depend of the phone and the developping.

Maybe your phone need a little more time of developping and with a little patience you will have a image of flashing who will resolve the problem, i see that for me with my lecoo pro 3 and my last install with the new image flashing with /e/ Q, it resolved a few bugs and now it’s perfect.

A thing alert me with your capture , i see LTE.
I had a similar problem than you, call your mobile operator, say you cannot detect your sim and ask to have a technical instructor to check all the paramètres.
Maybe you have to change some config, proxy etc, in the accès point.
You can have a surprise and discover that the config is not good.
You can change manually but you nead the bases config from your operator.
I did that, and after it was OK for me.
They send me a other card sim too to be sure, and it was better.
But now, i have in my computer all the capture image of the good config.

For your other question
In my phone, i see i can make calling with wifi if i activate the option but i have no icon, i will check later.

Good luck, you detect one time the sim, you have bigs chances to resolved the problem.

Hi guys,

I just wanted to give you an update regrarding my problem with my Oneplus 7 Pro smartphone.
I had the problem, that the device respectively the SIM didn´t connect to a service provider.
The probelm was, that the “e” OS needs to be flashed on all two slots, slot a and slot b and it is mandatory using the “e” OS recovery instead the TWRP, otherwise it doesn´t work.
But i experienced an issue with the update to v0.16. When the software update was finished, the phone didn´t start up again.
I tried a fresh install of v0.16 and it did work, but it was very annoying, that I had to reinstall all the apps and make the configurations to the phone, I had before. This error of the update took me about 6 hours, to get back to the state my phone was before the update.
I want to thank you for your help and endevour to solve my problem!!

Best regrads,

Fabian Orth